How do I enable wireless interface?

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64) : security ver 4.6

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) : standart

Configured to multiboot with other systems? (yes / no) no

List your networking hardware (make, model, firmware version): intel AC 9462

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

paste the output of


and also

lsmod|grep intel

in terminal (so we can see what interfaces are currently active/drivers installed) and we can go from there.

1 Like

Make sure your wireless driver is okay first.

1 Like

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::b7e7:d190:e3c3:8e4e prefixlen 64 scopeid 0x20
ether 08:00:27:85:9b:e6 txqueuelen 1000 (Ethernet)
RX packets 77005 bytes 90786553 (86.5 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 29783 bytes 2722063 (2.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 2916 bytes 939379 (917.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2916 bytes 939379 (917.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

snd_intel8x0 49152 3
snd_ac97_codec 151552 1 snd_intel8x0
intel_powerclamp 20480 0
snd_pcm 118784 2 snd_intel8x0,snd_ac97_codec
intel_rapl_perf 16384 0
snd 98304 10 snd_intel8x0,snd_timer,snd_ac97_codec,snd_pcm
crc32c_intel 24576 3
ghash_clmulni_intel 16384 0
aesni_intel 372736 0
aes_x86_64 20480 1 aesni_intel
crypto_simd 16384 1 aesni_intel
cryptd 24576 2 crypto_simd,ghash_clmulni_intel
glue_helper 16384 1 aesni_intel

that’s the thing I tried installing the iwlwifi and the compat wireless driver and nothing seems to work

did the driver install without error?

if so try this as root:

modprobe iwlwifi

I type in my root password and nothing happens… just returns to regular command line

try to remove then reload it once more:

modprobe -r iwlwifi

then reload it:

modprobe iwlwifi


See if it loads this time. I had to do this for a prev wifi card.

nothing shows up for either of the commands

if it helps any I copied the intel iwlwifi firmaware file into /lib/firmware/ and tried to load it with modprobe and nothing works

see if removing it and reloading it then rebooting fixes the issue.

As posted above, as root:

modprobe -r iwlwifi


iwlwifi iwlwifi

then finally to reboot:

shutdown -r now

you mean modprobe -r iwlwifi

and modprobe iwlwifi

well anyway I did it as well and still it didn’t fix anything - I still only have wired connection and no wireless

do you see your intel card name when running:


I just want to be sure we have the right card (and that it is detected).


here’s what I get

00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: VMware SVGA II Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC’97 Audio Controller (rev 01)
00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)

Weird I don’t see a intel wifi card. Although I’m not that familiar with apple computers TBH. Any problems using wifi cn this computer before now?

This is not an Apple PC it’s an Asus
I have no idea why I have the apple USB controller
and no I had no problems running wifi on this PC
just when I booted up my virtualbox I can’t use wifi only wired connection appears ( I need it for some local wifi scanning capabilities )

oh virtualbox. I did not know you were running Parrot in Virtualbox. Have you tried going into Network Manager to create bridge connection to host machine wifi connection to use the wifi internet? virtualbox apparently doesn’t detect wifi.

Network manager on what ? the VirtualBox VM settings? it’s already bridged connection and still the same

I did not know you already had a working internet connection in Parrot.

Unfortunately as far as I know you will not be able to do the wifi scans running Linux as virtualbox (someone correct me if you have other info). Your original post didn’t mention virtualbox. Virtualbox does not recognize internal wifi cards directly. Sorry I can’t be of more help.

But you can still run Parrot Live version to do your internal wifi card scanning operations.

You have the option of getting a USB card to use in virtualbox for scans etc.

Here is some more info from on networking:

Asus should use Aetheros device as i remember. The module iwlwifi is the 1 of so many packages that has wireless driver.