How do i update ZAP ?

I have been trying to look for a solution to help me update Zaproxy and none of them worked. There is a new version out and i downloaded the latests version. Now i am having trouble installing the latest version. I checked with the ZAP community and they told me Parrot OS community is my best bet for a solution.

Its just another issue i am having trouble with and need to figure out thank you.

1 Like

Thanking you and ZAP Community at first for recommending our Parrot OS Community .

Do you see any Update Dialog Box , or any other option on your ZAP GUI ? It should check for updates by default. Kindly check your ZAP configuration to confirm.

In case you want to install / re-install, run from your terminal: sudo apt install zaproxy

Its just i dont have the latest 2.11.1 i have 2.10.0 currently even though Parrot OS says i have the latest version. I dont understand what is the problem honestly all i want is to update to the latest version either through the command line or some other way.

└──╼ $sudo apt install zaproxy
[sudo] password for anthonyp:
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
zaproxy is already the newest version (2.11.0-0parrot2).
The following packages were automatically installed and are no longer required:
libct4 libmotif-common libxm4 python3-aiofiles python3-fastapi python3-orjson python3-pydantic python3-slowapi
python3-starlette python3-uvicorn sqsh
Use ‘sudo apt autoremove’ to remove them.


Correction i have 2.11.0 NOT 2.11.1 and i always get reminded about it this is a ongoing problem.

1 Like

I understand that you need 2.11.1 version. Here is the official link: Release v2.11.1 · zaproxy/zaproxy · GitHub . Another link containing the ZIP format for your convenience: Releases · zaproxy/zaproxy · GitHub . Install from here.

Hope these help.

Try get 2.11.1 from rolling-testing branch

Thank you i will check it out hope it works.

But what i am really asking for is the command line commands to update the tool itself ?

sudo apt install zaproxy itself updates, to confirm the latest stable version, run apt-cache show zaproxy

I ran these commands and i still have 2.11.0 and not 2.11.1 version even though it says its on the latest version which is not true.