How to automaticall disable touchpad when typing.

So I have just installed parrot os and the feeling is amazing.But my issue is , when am typing, my hand keeps moving the cursor with the touchp ad. So I wanted to know if there is a way I can setup the computer so when I am typing, the touch pad would be automatically disabled.
Then when I stop typing, I can it would automatically resume the touch pad for.
Any help would be appreciated. thanks

1 Like

In order to configure your touchpad settings through the dconf Editor, you first need to install it by running the following command in your Debian Terminal:

sudo apt-get install dconf-editor

launch it through the command line by entering the following command in your Terminal:

dconf-editor

The dconf Editor will launch, displaying the following message:

image
The message means that you need to be very careful while performing system configurations as it might mess up with sensitive settings and break down your system. After clicking the “I’ll be careful” button, search for touchpad through the search button. This will display the following results:

Click on the /org/gnome/desktop/peripherals/touchpad/ folder. This will open the following view:

aaaaaaaaaaaaaaaaaaaaaaaa

Try to locate the Custom value drop-down and select the “disabled-while-typing” option as shown above. Now save the settings and close the dconf Editor. Now your touchpad will automatically become disabled every time type.

Let me know if you face any problem and Accept our warm Welcome in our fantastic community. We are glad to have your presence in our Parrot Community. Feel free to ask and contribute.
Thanks :slightly_smiling_face:

[Edited]

2 Likes

wow. Thank you very much but my question was about auto disabling the touchpad when I am typing not external usb.
when am typing anything on my laptop, my hand touches the touch pad and and it usually mess up my typing experience

1 Like

@vendettaboss follow the tutorial until here,
then as you can see in the picture there is an option disable-while-typing
just enable that and restart
then you should see touchpad not working when you are typing something

Thanks for this Correction.

From the menu bar find System, under Preferences find Hardware select Mouse, notice the “touchpad” tab at the top of the dialog window next to Mouse…enough said. Try exploring the settings and the interface a little.

3 Likes

where is the org/gnome folder located?

Well you can try another easy way suggested by @muroga

From the menu bar
go to System>>Preferences>>Hardware>>Mouse
Then click on Touchpad tab
There you can see Disable touchpad while typing just click it then close
now reboot and then you can see

1 Like