How to switch from intel to Nvidia graphics card ?

Briefly describe your issue below:
I’m using parrot from past few months now and have no clue if its using Nvidia graphics card, so how do I know that my parrot is using Nvidia graphics card over intel ?
Reason for this is sometimes my parrot take too long to boot up (sometimes take around 5 mins just to restart system) or run apps. So I was thinking if my graphics card might come in handy.
I have 8GB RAM with i7 8th Gen.
My laptop: Dell G3 3579
To install nvidia drivers I used this command and reboot the system after this:
sudo apt install nvidia-driver nvidia-smi nvidia-opencl-icd
Im sorry if it sounds like a silly post. Thanks in advance <3

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Linux parrot 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

Configured to multiboot with other systems? (yes / no)
Yes… Dual boot with Windows 10

List your hardware specs to include make, model and firmware (when applicable):
Intel Corporation UHD Graphics 630 (Mobile) want to switch to
NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile]

If there are any similar issues or solutions, link to them below:
I have read some articles saying that installing nvidia-prime will help but its not in my apt repo.
I was following alot of articles but all seems to show this method.(Its for Ubuntu ik)

https://www.linuxbabe.com/desktop-linux/switch-intel-nvidia-graphics-card-ubuntu#:~:text=Click%20PRIME%20Profiles%20tab%20on,select%20Intel%20in%20PRIME%20Profiles%20.

If there are any error messages or relevant logs, post them below:
When I run

 ____ $nvidia-settings                                                                                                                                                                         
                                                                                                                                                                                                  
    ERROR: Unable to load info from any available system 

I have installed nvidia-settings. Dont know why I get this error.
---------lspci -v
Intel Drivers: lspci -v

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (prog-if 00 [VGA controller])                                                                                  
        DeviceName: Onboard - Video                                                                                                                                                           
        Subsystem: Dell UHD Graphics 630 (Mobile)                                                                                                                                             
        Flags: bus master, fast devsel, latency 0, IRQ 127, IOMMU group 2                                                                                                                     
        Memory at a2000000 (64-bit, non-prefetchable) [size=16M]                                                                                                                              
        Memory at 80000000 (64-bit, prefetchable) [size=256M]                                                                                                                                 
        I/O ports at 5000 [size=64]                                                                                                                                                           
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]                                                                                                                            
        Capabilities: <access denied>                                                                                                                                                         
        Kernel driver in use: i915                                                                                                                                                            
        Kernel modules: i915

---------lspci -v
Nvidia Drivers:

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
        Subsystem: Dell GP107M [GeForce GTX 1050 Ti Mobile]
        Flags: bus master, fast devsel, latency 0, IRQ 144, IOMMU group 1
        Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
        Memory at 90000000 (64-bit, prefetchable) [size=256M]
        Memory at a0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        Expansion ROM at a4000000 [virtual] [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nvidia

https://www.youtube.com/watch?v=iYWzMvlj2RQ He is Linus Torvalds Father of Linux kernel

is your comment relevant to the post?
Linus Torvalds is the father of Linux Kernel and Richard Stallman is the father of GNU system.
Both combined, its GNU/Linux, and operating system built and based on GNU/Linux are called GNU/Linux distros not linux.

2 Likes

Any of you know how to solve this error ?

Sorry my friend but i was taking it Generally, btw Thanks for telling

for installing the drivers
please go through official documentation: https://www.parrotsec.org/docs/info/gpu-drivers/

I did man ! When I did test run like in the documentation… it worked without any issue but when I finished the documentation(ie. appending into file/ creating file like in docu ) and reboot the system I got this error.

____ $optirun -vv glxgears
[ 2282.865206] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 2282.865487] [DEBUG]optirun version 3.2.1 starting...
[ 2282.865492] [DEBUG]Active configuration:
[ 2282.865494] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 2282.865496] [DEBUG] X display: :8
[ 2282.865498] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/x86_64-linux-gnu:/usr/lib/i386-linux-gnu
[ 2282.865500] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 2282.865502] [DEBUG] Accel/display bridge: auto
[ 2282.865504] [DEBUG] VGL Compression: proxy
[ 2282.865506] [DEBUG] VGLrun extra options: 
[ 2282.865508] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 2282.865593] [DEBUG]Using auto-detected bridge primus
[ 2282.865779] [INFO]Response: No - error: Could not enable discrete graphics card

[ 2282.865786] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 2282.865788] [DEBUG]Socket closed.
[ 2282.865794] [ERROR]Aborting because fallback start is disabled.
[ 2282.865797] [DEBUG]Killing all remaining processes.

I keep searching for this error but havent got any further.

is the bumblebee service started correctly?

systemctl status bumblebeed

also is the user on bumblebee group?
if not add and try restarting the bumblebee service

after that

  • sudo tee /proc/acpi/bbswitch <<<ON
  • optirun glxspheres

check this: https://github.com/Bumblebee-Project/Bumblebee/issues/85

Thanks for replying so early <3

I dont know but I uninstalled packages, removed files I created from documentation and I did followed whole documentation again. Now it’s working perfectly.
I guess when I installed them on first time I remember I had nvidia-driver and some other nvidia related updates… after updating I did “lspci -v” and I was getting following error

______$ lspci -v 

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev ff) (prog-if ff)
        !!! Unknown header type 7f
        Kernel modules: nvidia

maybe that broke something after updating.

But now its working. Thanks for replying again !!

cool brother