I lost the mate-panel application

Lose my menu applications item

Sorry, I lost the application items in my menu

i have edited the menu, after, the menu went wrong, and i can’t open an application menu anymore

I tried
menu-panel --reset

Or

re add a panel to panel

Or

mate-tweak

Panel

Panels --> Save as...

But all didn’t work


Finally: I can’t see any applications items

%E5%BE%AE%E4%BF%A1%E6%88%AA%E5%9B%BE_20181224175600


What version of Parrot are you running? (include version, edition, and architecture)
Linux parrot 4.18.0-parrot20-amd64 #1 SMP Debian 4.18.20-2parrot20 (2018-12-10) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
No, just vmware

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

please include the form that has all of the pertinent information for you to include so we may give accurate advice; going back to the default panel, it looks like when you changed it that it didnt include any apps or something like that where they were not selected and it essentially just replaced the default with an empty custom panel

fine, i have re-edited it

is it 4.4? did you try and seeing if the default and maybe just changing the language would work for you? what were you trying to change exactly?

i have edited the menu, after, the menu went wrong, and i can’t open an application menu anymore

did you change it back in the settings panel? thats what Im trying to tell you to do

yeah, i tried “mate-panel --reset” or “mate-tweak Panel–> Save as” or “del & re add a panel”

at this point I would say reinstalling will be much quicker and easier for you to do. you could try

sudo apt remove --purge mate-panel mate-tweak

and then

sudo apt install mate-panel mate-tweak gnome-system-tools

but if no success you should most likely chalk it up to a lesson learned and practice gained and start fresh and see what you can do better for your system versus before; I used to make a game out of it to ease my anger at myself for creating FrankenParrots

tks, i’m reinstalling mate :+1: :smile: :smile: :smile:

The problem has been solved,rm -rf ~/.config/menus,tks @Nico_Paul

1 Like

of course i dont know why I didnt think of the best command for you there is!

sudo apt install parrot-mate

EDIT(sortof) I thought I had pressed post but i guess not, sorry if this is late but i beleive this is the MATE desktop environment command you may have to

apt remove --purge
first but try that and see what you get otherwise itll be so much faster for you to start over

that is actually a better solution (removing the config for the menu) as it is more targeting the only actual problem rather than the parrot-mate suggestion because mine would have been acting upon a lot more than the menus; great job!