Impossible parrot-upgrade: libcupti10.1 corrupted

My Parrot information

    ```

DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.10
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION=“Parrot 4.10”
PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.10”
VERSION_ID=“4.10”
HOME_URL=“https://www.parrotsec.org/
SUPPORT_URL=“https://community.parrotsec.org/
BUG_REPORT_URL=“https://community.parrotsec.org/
```

  • Kernel version:
    Linux <redacted> 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

Usually, everything just works fine. I’m using Parrot as my main host desktop system.
Built-in GPU:
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

Using your guideline for driver installations worked well back then. For approx. a month, I cannot do any parrot-upgrade anymore because of a ?lib version conflict?.

The following packages have unfulfilled dependencies:
  libcupti10.2: Damaged: libcupti10.1 (<10.1.243-7 ~) but 10.1.243-6 should be installed
E: Error: interrupts caused by pkgProblemResolver :: Resolve; this could have been caused by retained packages.

Any ideas?

Greetings!

Solved it myself…simply apt remove libcupti10.1
Then proceed normally.