Impossible to BOOT ParrotOS on USB key

I’ve downloaded the latest version of ParrotOs from Parrot website and put it on a USB key to be able to boot my laptop with it. However, after pressing F12 and choosing to boot from my USB key, the screen is stuck on “ISOLINUX 6.04 20190226 EHDD”, I’ve waiting for 6 hours maximum so I can say it’s really stuck. I’ve tried everything, to change the USB Drive, changing the USB port, using another way to copy the files on the USB Drive, downloading from an official mirror or from the official torrent but the result is always the same.
Also, I’ve tried to boot it on my MacBook Pro 2018 and everything was flawless, booting perfectly and quickly.

So my question is, why it can not boot on my Acer PH300 and what could I do in order to boot it ?

Version : Parrot Security MATE 4.7 x64

Thank you very much for your help

No, no one knows why a particular model machine you have has this problem because we do not know about your machine(so tell us!) :smiley::sweat_smile:

But no really I would the same things you did with the Mac to ready it for USB booting you would to the other machine. I cant imagine why that wouldn’t work. Maybe it can not boot from USB, though that seems improbable…
Is it very new, maybe its controllers use significantly specialized or recent firmware that Linux doesn’t suppport yet.

Just to be clear you 1. Turn off secure AND fastboot 2. Enable USB boot specifically if necessary in that particular BIOS 3. Change the boot order if needed
Some UEFI firmware has many configurable options, perhaps look yours over there may be a small error

First of all thank you very much for your interest in my problem.

My laptop is pretty recent, it’s a Acer Predator Helios 300, 16GBDDR3, 256GB SSD and 1To HDD.

Windows is running on it with a multi boot with kali on another partition.

Needless to say that I’ve indeed installed kali from USB and it’s always booting without any problem, and I did it with the same USB key.

About the bios, I deactivated UEFI boot and activated Legacy Bios (as I did to boot kali). The boot order allows to boot from the USB key first so no problem on this side.

In fact the problem is not to boot the USB key, but it’s more once the USB key booting process has been engaged then it stays on this screen :

really weird …

I’ve finally been able to boot using a lower capacity USB key. It seems that the system won’t boot using 64GB keys, I tried 5 different 64GB USB keys and same result. Just tried with one 8GB USB key and it’s booting perfectly.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.