Impossible to erase Parrot from USB


I installed Parrot on an USB key without any problem (standard install, full drive with LVM).
It’s working but not exactly the distro i need so i want to format my key but it’s impossible.

I tried Gparted, many partition softwares on Windows, fdisk, diskutil on mac…
Impossible to format or delete partitions, impossible to flash another distro on the key.
Every time i have error or nothing happen.

Parrot still working fine after all this…
I don’t have idea anymore to erase the disk.

Can someone help me please ?


I’ve never had this happen before…I have had my usb erase itself upon install…But never not been able to erase one. So I’m interested to see what others have to say about this topic.

Is there some kind of error that is generated when you use a program to try to repartition it? If you used logical volume management(LVM) you may have to offline the volume group first.

Have you tried command line?

First identify your usb drive device. Then issue:

sudo mkfs.ext4 /dev/sda1
(where /dev/sda1 is your usb device)

Please let us know how this goes. I promise Parrot has not taken over the USB stick

It’s seems to work… but no :frowning:

Screenshot_2020-01-09_16-12-31 Screenshot_2020-01-09_16-40-50

I know it’s not a problem from Parrot… something probably go wrong during the flash…
But wat ?

I’m stuck with a parrot now :rofl:

this should do it by overwriting everything (including partitions) with 0’s:

dd if=/dev/zero of=/dev/mmcblk0 bs=1M

seeing your drive was /dev/mmcblk0 the above should do it :slight_smile:

it’s amazing … it still doesn’t work!

dd worked as expected, lasted several hours, indicates that everything is ok but no.

the partitions are identical and Parrot continues to operate on the sd card as if nothing had happened.

it annoys me not to understand! :smiley:

Screenshot_2020-01-10_14-09-42 Screenshot_2020-01-10_14-10-18

1 Like

fdisk /dev/mmcblk0 and just write a blank partition table on the device… and burn again from scratch.

Remove the contents of the extended partition first. I believe the existence and encryption of /dev/mmcblk0p5 prevents it from being removed. I’ll also submit the wipefs tool as a potentially useful helper, as the name suggests its designed to remove filesystem signatures.

1 Like

Why /dev/mmcblk0, not /dev/sdX? You use SD or MicroSD + Adapter? If the answer is yes, maybe your card just locked?



sorry i was offline for some days.

the card is a microSD and my laptop have a microSD reader integrated (not SD).
i tried with and without a USB adapter.

impossible to erase content on any partition, maybe my card is locked indeed but how can i unlock it ?


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.