Install on lenovo T490s fails

Briefly describe your issue below:
I’m trying to install Parrot-security-kde on a lenovo T490s laptop, I can get the OS to load a live boot screen but nothing else on my test laptop. I tried on the T490 and it doesn’t even show the boot screen to select live install.

Any help is appreciated

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
KDE and Home
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)
If there are any error messages or relevant logs, post them below:
On enter the boot manager starts the HostOS

Be as descriptive as possible in your question. There are so many different possible problems with a vaguely asked quesiton like this. Please give as many details as you can about your experience and tell us everything you already did try to fix this issue. This way we know what has already been tried. The more details you give the more likelihood we can pinpoint the problem.

I have had success with multiple lenovo laptops so we should be able to help you. TIP: Do not use the install parrot on live desktop- I had problems with this.

Did you change bios settings for Linux (legacy, secureboot settings, UEFI)?

What did you see (exactly in detail) after install/boot?

What do you mean "boot manager starts HostOS? Are you saying it just loads windows or is there an OS called HostOS? Please be more detailed.

How did you setup the partitions? Any issues?

Did you get any other errors during install? (like configure package manager error or something else?)

Please be descriptive so we can better help. :slightly_smiling_face:

Thanks for reaching out, essentially the laptop defaults to showing the lenovo boot options after i select the USB drive with parrot on it; i’ve flashed it with dd
I’ve tried two lenovo laptops, with an older model being able to start the USB and open up the parrot install/live boot page. Selecting install with and without gtk fail on the old laptop ( i’ll grab a screen shot of this when i get back to work ), with the newer one going back to the lenovo boot options menu. With the new laptop, I select the drive parrot is installed on, the screen goes blank and returns to the boot options.
I have ubuntu18 installed on both machines, the bios settings were adjusted. I did not get to the point to partition the disks on either machine.

I’ll post any media I can collect today or possibly tomorrow

Newer Lenovo bios is more tricky than old (I’ve installed on like 6 Lenovos so far). The UEFI & all that.

I have a 2019 built Lenovo that took a bit of configuring to get it to boot properly. (It appears Intel & Microsoft/OEM isn’t making it easier to attract new Linux user installations)

You may need to turn off RST and switch AHCI on instead. Newer Lenovo BIOS can give problems. Try turning off secureboot. UEFI (Legacy support mode if available). You didn’t list your bios settings so I am doing my best with the info you gave. Make sure to do the EFI partition and make it the right format etc.

Let me know how it goes for you :slight_smile:

It was SecureBoot, or well, layer 8 stopping me
I appreciate the help

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.