Installation of Nvidia Drivers messed with my firmware?

Hello. Please bare with me. I can’t boot into my OS, so I’m going to provide as much info as I can.

  • OS version: Version 4.10

  • Kernel version: N/A

Or if you can’t do it, please tell us ISO version you downloaded.
Couldn’t say. I still have my live boot drive, but I’m not seeing anywhere to tell the version. I just d/l’d it two or three days ago. My machine is AMD64, and it’s not the version for the virtual machine. I’m sorry, I’m doing this on my phone.

Version: 4.10
Desktop Environment: KDE
Edition: Security

2. If you have this problem after fresh installation:

OS was running fine all day until I tried to install Nvidia drivers, so I don’t think it’s install related.

Hardware information

- Your device name or output of `lspci`

HP Omen 15-dc0051nr
Hardware causing issue: Nvidia GeForce GTX 1060
- Did you try searching info about this issue on search engine? Please write No or any URL to this issue bellow
Yes, but did not find another issue like mine. It happened as I was following the guide from the main parrot OS website:

4. How did you get this error? Are there any steps to procedure it?

1. I installed this: Nvidia GeForce GTX1060 driver
     I was instructed in Konsole to reboot to disable the Nouveau driver.
3. It shows me this or that: Upon reboot, I was given an error, after Grub, that the firmware failed to load. Error message included in screenshot. 

Upon rebooting into recovery, I am unable to login with my root password, though I have it written down and have probably used it a hundred times today. So, I am unable to perform maintenance. When I press ctrl + D to skip login, the system just hangs.

5. Error log or screenshot

** Insert error log and screenshot here**

6. If you have any idea or suggestion about this issue please tell us

I’m at a total loss. Should I just live boot from my drive and start over?

Did you try systemctl enable nvidia-persistenced?
It is a little weird because i’m having a PC with Nvidia GTX 1060 MSI 6gb. The nvidia-driver works just fine here. Ofc the device on PC is different from Laptop.
Did you check any error log from journalctl? It could help detecting errors

Update: I’ve managed to get back into parrot, but my display is kinda messed up. Can’t change resolution (which is kinda wonky) or use extended mode for dual-monitor. I’m finishing the guide I started above (I had rebooted midway through at what seemed like a good spot, guess not). Then, I’ll go to work clearing the rest of the errors.
I had not checked the logs as of the original post. I was having a hard time logging in at recovery, but I figured it out. I’m hoping I can get full display functionality from the proprietary driver, otherwise I’ll have to just go back to nouveau. I only did all this because VLC was a little choppy, and it really should not be on this machine. She’s a beast.
Anyway, thanks for the good word. I have the exact same 6gb MSI as you, so I’m sure I’ll get it hashed out eventually. Got any install tips, or a reference I can look at to iron things out?
Thanks again.

Joke’s on me. I tried to finish the f’n guide, and made everything worse. Now x server won’t start and I’m back to command line. FML. How do I go about reversing what that damn guide told me to do?

Update: I’m in parrot. I just need to go back to where I started, before I followed the guide at
If you have advice, that’d be great. I’m gonna start from the end, and undo everything, one step at a time.

This thread can be closed. I’ve reinstalled. No reason to waste my time troubleshooting a system that’s one day old.

wait a sec i think the nvidia card on laptop is different from PC even it has same brand name (i have no knowledge about hardware so that is what i’m suppose).
Well to be fair you don’t really need to install nvidia-driver if kernel or preinstalled driver supports your graphic card (ofc the onboard graphic card is using and nvidia is disabled doesn’t count). But if you want to use 100% your graphic card like playing game or using hashcat, install nvidia graphic is recommended.

I see your point. If the issue happens to get back to the top of my to-do list, I’ll go about it differently, to be sure. I do game, but haven’t had time in a while, so it wasn’t a priority when I was considering switching from windows. I’m sure I’ll get it handled eventually. Thanks again.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.