Installation step failed Parrot 4.10

I already had Parrot in my PC. But i got some dependency issues so i decided to reinstall Parrot.

I downloaded Parrot security MATE 4.10 and checked its hashes.
But when i tried to install it on my PC, i got error ***Installation step failed ***. No matter how many times i try. I also tried to install it on other PC, But that didn’t work too.

I have used:
to burn iso file to usb

After too many tries i tried to install Kali Linux. And Kali was installed without any issue.
Please help me
I wanna use PARROT.

Please try again with etcher then go to live mode and use installer from live mode.

And it is helpful if you can show the log of errors during install if you use Debian’s installer. It should be Alt + F4 i think

I have tried installation from live mode too
And i have also tried to install from booting GTK installation

I guess you want this
I get these logs by CTRL + ALT + F4

This problem is there because your USB is broken. It could be USB port isn’t stable or something so USB was “unplugged” during installation. Or it could be broken ISO.

Installation from LIve Mode
I’m getting this error

Thank you very much for the help

I don’t know why, but i was able to install parrot after disconnecting my Live Parrot from internet

I had the same problem where I could not install any OS. My problem was secure boot was enabled in BIOS.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.