Internet stop working after I've started ANONSURF

I have to reinstall Parrot OS from scratch as well. Messing with anonsurf completly destroied my system. Nothing was working correctly. So now I’m back to position when I have to tape in sudo tor -f /etc/anonsurf/torrc.

dudes… don’t use the sudo apt remove if you want to reinstall a package because it can mess your system. Use sudo apt install <package_name> --reinstall instead. Btw rm: cannot remove ‘/etc/tor/torrc’: No such file or directory -> create the file by sudo touch /etc/tor/torrc.

You have to check the files by read it or check if 1 file is symlink :sweat_smile:

I’m very sorry. I’m not sure what is wrong with your anonsurf. Well i meant i tried to do the “remove the torrc” after torrc was generated. I found out it was a mess and i removed it. IDK if Palinuro updated my code with the remove.
P/s: I’m working on the logic right now. I have to change the torrc behavior to fix it completely

1 Like

Thank you for advice dude, didn’t know that nuance. I’ll try to do all you said and give response asap.

Hi and thank you for your effort for helping us. But as I mentioned before. I’am stuck at position when I have to run sudo tor -f /etc/anonsurf/torrc.
Could you please make some changes or tel me what changes I have to do in my config file not to manually type in taht command before runing anonsurf.

Yes it should be easy. The problem is our current version is using tor as a system service. It can lead some more trouble.
I also want to make control port password be a random password every time it start new torrc file but it also can lead more trouble.
The enable boot and disable boot is having trouble because we don’t want it to boot with system right after it was installed and we didn’t test it fully.
So yeah it is all plan. It can be done but we don’t have any quality control for the code. By now any change is just “this seems like a good idea”. New structure is good but new code has random problem that we can’t spot at test. weird and bad.

1 Like

Anyway thank you all for the bug reports. We couldn’t improve our quality without your supports!

1 Like

Reinstalling anonsurf and tor via “** sudo apt install <package_name> --reinstall**” solved my problem everything is working fine now. Thank you dmknght! :fist_right:

Edited: when i check anonsurf status i got this message:

16:47:14 [WARN] Application request to port 80: this port is commonly used for unencrypted protocols. Please make sure you don’t
send anything you would mind the rest of the Internet reading!

Dude, i’ve found solution for me. I’m pretty sure it will help you too

Did you create the /etc/tor/torrc file?

Well, I have no luck as you noob_admin. When I tried a command “sudo apt install anonsurf --reinstall”, received an error that “/etc/anonsurf/torrc” file does not exist so I cannot reinstall it. So what I have done (temporary). I have created a launcher on my desktop which run a command “sudo tor -f /etc/anonsurf/torrc” and its opening in terminal. After that I can start anonsurf and its working fine. But still problem exists, so I hope that will be some upgrade soon.
noob_admin what have you done exactly apart reinstalling an anonsurf aplication? Maybe I have missed sth?
Thanks dmknght for help as well.

Yes i did.

try to create missing file first.

Now i’m wondering why you two had that problem. Can you find the make_torrc in /etc/anonsurf? Or this is the symlink problem.

Greetings. I deleted the previous post as I was able to get things up but after two fresh installs.
I was also able to issue the anonsurf status command without being asked for controller password.

However after a third fresh reinstall, I was not able to recreate what I had done to get up and running (custom torrc coppied and edited from the torrc.orig).

However after hours of testing I was able to get on by with a fresh install.

sudo touch /etc/tor/torrc
sudo apt install anonsurf --update
sudo apt install tor --update
sudo tor -f /etc/anonsurf/torrc
sudo anonsurf start

At this point I can see that I am connected to tor with http://ip-check.info.

But issuing anonsurf status command still ask for password

1 Like

do you know what the hell are you doing or you just copy bunch of random commands an run?

I had a problem and happened to fix it with help here. I was just trying to recreate to help others. Thanks for the great welcome to the community.

I ran into the same issue.
It is running anonsurf for me now but with the command sudo tor -f /etc/anonsurf/torrc.

Steps I followed:
sudo apt install tor --reinstall
sudo touch /etc/tor/torrc [ Since there was no file with the name torrc]
sudo apt install anonsurf --reinstall
[Checked the make_torrc in /etc/anonsurf and ‘make_torrc’ exists] but i still have to use the sudo tor -f command before starting anonsurf.

after all the steps anonsurf status command is giving me the below:
└──╼ $sudo anonsurf status
Tor controller password:
(Which i am not sure as to what to do).

Also are there any further developments that have happened to avoid using the sudo tor -f command for using anonsurf ?

Thanks to dmknght :slight_smile:

@PTester1 @noob_admin just asking: did you run as cli or menu?

status doesn’t require sudo.

Torrc is used to make new torrc inside anonsurf. The scope is making normal anonsurf connection and conection + obfs4 bridge. Start Tor should be in the bash script.

Did you run from menu or cli?

It was from CLI.