Internet stop working after I've started ANONSURF

Greetings. I deleted the previous post as I was able to get things up but after two fresh installs.
I was also able to issue the anonsurf status command without being asked for controller password.

However after a third fresh reinstall, I was not able to recreate what I had done to get up and running (custom torrc coppied and edited from the torrc.orig).

However after hours of testing I was able to get on by with a fresh install.

sudo touch /etc/tor/torrc
sudo apt install anonsurf --update
sudo apt install tor --update
sudo tor -f /etc/anonsurf/torrc
sudo anonsurf start

At this point I can see that I am connected to tor with http://ip-check.info.

But issuing anonsurf status command still ask for password

1 Like

do you know what the hell are you doing or you just copy bunch of random commands an run?

I had a problem and happened to fix it with help here. I was just trying to recreate to help others. Thanks for the great welcome to the community.

I ran into the same issue.
It is running anonsurf for me now but with the command sudo tor -f /etc/anonsurf/torrc.

Steps I followed:
sudo apt install tor --reinstall
sudo touch /etc/tor/torrc [ Since there was no file with the name torrc]
sudo apt install anonsurf --reinstall
[Checked the make_torrc in /etc/anonsurf and ‘make_torrc’ exists] but i still have to use the sudo tor -f command before starting anonsurf.

after all the steps anonsurf status command is giving me the below:
└──╼ $sudo anonsurf status
Tor controller password:
(Which i am not sure as to what to do).

Also are there any further developments that have happened to avoid using the sudo tor -f command for using anonsurf ?

Thanks to dmknght :slight_smile:

@PTester1 @noob_admin just asking: did you run as cli or menu?

status doesn’t require sudo.

Torrc is used to make new torrc inside anonsurf. The scope is making normal anonsurf connection and conection + obfs4 bridge. Start Tor should be in the bash script.

Did you run from menu or cli?

It was from CLI.

I have the same problem with anonsurf with fresh installer Parrot Security KDE ISO 4.9.1.
Internet work but when I start anonsurf in command console or in the menu bar it will result with no internet, no matter what I just do will result with the same problem I was create sudo touch /etc/tor/torrc reinstall and install anonsurf and tor but problem is still there, only temporary fix for now is this command “sudo tor -f /etc/anonsurf/torrc”.
Now I want to ask @dmknght is still work correctly internet with this command? I mean in security connection I don’t want to surf unsafe. Hope you will fix this bug.
I’m new user on parrot os so I guess i’m unlucky welcome on this os. ^_^"

EDIT: when I type anonsurf ip in console it show blank it’s normal?
It’s wierd even if it work with that comand force still don’t see the anonsurf ip.

Yes. All the test worked well. Other members had good connection. I must test again in fresh 4.9.1.
We are working on calling tor in new way so we can get rid of the torrc configuration symlink.

Yes. We know that. That is from our server side. Palinuro didn’t add new IP show on server.


Run from live mode. Everything is fine.

Hi there, everyone!
I getting the exact same problems described above after a fresh install.
It’s the 4.9.1 MATE version on a VMware Workstation Player. The network adapter is configured to NAT. It looks like the /etc/tor/torcc file do not get generated/linked properly by the script.
Running the tor command with the config file before anonsurf start solves the issue for me too, and the status command asks for a (not user) password afterwards.

The first thing I did after install is a full apt-get upgrade. Maybe some version incompatibility?

Thanks for your work dmknght.

OFF: btw can someone tell me how is it possible to ping/nslookup with active anonsurf connection? If i know it right tor network uses tcp only, so the ping’s ICMP shouldn’t get through, but it works somehow.

symlink was made by postinit script during anonsurf installation. It could be broken when tor has an upgrade on system.
Memory flash back: I reported a bug that AnonSurf couldn’t connect internet and torrc must be replaced. I reported to Palinuro before i knew who was he LUL. I think i can say this case is similar.

I added code to the make-torrc which make new symlink everytime anonsurf starts and restore previous files when it stops. I still have to think about handle other situations but basically it can work.

I still don’t know what made this problem. That makes everything be harder because i want to generate random Tor password everytime anonsurf starts. By now it is using only 1 hard coded password so this problem is a ?????

Yeah the postinit thing only works when anonsurf is installed. Tor installation /upgrade can replace torrc

It uses SOCK5 protocol. If you want to check public IP, any online service is a good idea.

Thank you for your support. We couldn’t improve our project’s quality without you guys. <3

Hi I am having the exact same problem. Anonsurf is not connecting. Not sure how to fix it. I am seeing you already added code to make-torrc … so I did an apt full-upgrade … but there was nothing for anonsurf there. Still experimenting the same issue.
It works doing the workaround found in this thread : tor -f /etc/anonsurf/torrc first and then launching anonsurf but I would like to know if this is now fixable.

└──╼ $cat /etc/lsb-release 
DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.9
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION="Parrot 4.9"

> └──╼ $sudo anonsurf start
> [*] killing dangerous applications
> [*] Dangerous applications killed
> [*] cleaning some dangerous cache elements
> [*] Cache cleaned
>  * Generating torrc
>  * Starting tor service
>  * Making firewall rules
> 
> [ i ] Starting anonymous mode:
> 
>  * All traffic was redirected throught Tor
> 
> [ i ] You are under AnonSurf tunnel

Doing cat /etc/tor/torrc shows me the file is empty.

This is the content for /etc/anonsurf/torrc :

 # Dynamic torrc file generated by anonsurf
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN


##define virtual network mask
VirtualAddrNetwork 10.192.0.0/10
AutomapHostsOnResolve 1
AutomapHostsSuffixes .exit,.onion

#define tor ports and explicitly declare some security flags
TransPort 127.0.0.1:9040 IsolateClientAddr IsolateSOCKSAuth IsolateClientProtocol IsolateDestPort IsolateDestAddr
SocksPort 127.0.0.1:9050 IsolateClientAddr IsolateSOCKSAuth IsolateClientProtocol IsolateDestPort IsolateDestAddr
ControlPort 9051

#use tor to resolve domain names
DNSPort 127.0.0.1:53

#daemonize
RunAsDaemon 1

#use hardware accaleration when possible for crypto
HardwareAccel 1

#socket safety hacks
TestSocks 1
AllowNonRFC953Hostnames 0
WarnPlaintextPorts 23,109,110,143,80

#dns safety hacks
ClientRejectInternalAddresses 1

#circuit hacks
NewCircuitPeriod 40
MaxCircuitDirtiness 600
MaxClientCircuitsPending 48
UseEntryGuards 1
EnforceDistinctSubnets 1

HashedControlPassword 16:FDE8ED505C45C8BA602385E2CA5B3250ED00AC0920FEC1230813A1F86F

Thank you for your hard work on this :slight_smile: we all appreciate it.

Insert the following command
cat /etc/resolv.conf
then reply with the output :slight_smile:

Hi Snowflake. The DNS is set to 127.0.0.1 after connecting to TOR which makes sense since it queries it through tor as well.

@PTester1 @noob_admin if you are still having this problem, please help me run sudo service tor restart after start anonsurf. Also please check if torrc file from anonsurf and tor is the same before restart service.

Hi,
After restarting tor nothing has changed. Config both files remain the same. So still stuck at point that I have to manually start tor and then start anonsurf.

It is strange. It would be nice if any device of mine has problem so i can debug it.
p/s: nvm my laptop has that problem. I am going to track it down tonight.

The status asks for password: It can be used after i entered password. Tor worked for me. Sometime it doesn’t work and sometime it does. I must do more test to find out what is the problem.
I didn’t see the tor is not running after start anonsurf. All anonsurf’s ports opened. All configs are the same. All firewall rules was fine. DNS was good. I don’t understand the problem.


Here is my result. Nyx worked good after i provide control password. Internet connection still worked. I have to read everything from bug reports again.