Invalid Partition Table on Boot

I’m trying to install Parrot 4.7 on a Dell Ultrabook. I have been using the Standard Installer and everything goes smoothly. After installation finishes, I remove the flash drive and try to boot into Parrot. Every time, it says “Partition table invalid!” over an all black screen. Does anyone know how to fix this?

Can you show us what your partition table looks like so we can better assess it?

parted /dev/sda print

where /dev/sda is your disk. Try to include anything you have already tried so we avoid offering the same solutions

I booted into live and ran the command you provided. The picture is the results that I got:

Not sure if this helps, but during the partitioner setup I also used the Guided – use whole disk, and and I didn’t configure swap space. I’m really stuck and I don’t know what to do. Support would be greatly appreciated.

What does your BIOS boot setup look like? What kind of BIOS settings have you changed to try to get the system to boot? You may want to try setting boot flag as it doesn’t look like you have done so yet.

Boot Parrot Live session and bring down Applications menu. Then go to “System Tools”. Now select/open Gparted. This should load your current partitions. Go to Manage Flags and set the first partition to have a boot flag. Apply all operations.

Try booting your newly installed system (Sorry it took me some hours to get back to you, haven’t had access to computer today).

Let us know how it works out when you try booting with the boot flag. We will go from there :slight_smile:

So I booted into Parrot Live, and I flagged the partition labeled ‘boot’ as boot in Gparted. But now when I try to boot I am greeted with a black screen and a white flashing underscore at the top left of the screen.

Have you tried pressing enter? Sometimes this will progress into boot (GRUB quiet is likely set to prevent you from seeing the messages).

What are your BIOS boot settings? Does bios force UEFI? Did you try disabling secureboot & enable any Legacy Support/UEFI modes? Your system may require an EFI partition meaning fat32 type.

If your system is newer like mine it may require fat32 EFI partition. You might want to recreate partition table w/this fat32 partition at the very beginning with boot/esp flags. Then reinstall Parrot Linux using this partition table. But this is just guessing as you haven’t given us bios information.

Please give more detail on BIOS so we can give you the best path forward.

As long as you don’t give up we will get your Dell running Linux (as it should be :stuck_out_tongue:)

Pressing enter does nothing on boot. As for BIOS settings and your suggestions:

  1. My boot mode is set to Legacy and Secure Boot is off.
  2. I don’t know if it forces UEFI (not sure how to check that either).
  3. I changed boot mode to UEFI, secure boot off, and it couldn’t find any bootable devices, so I don’t think this will work either.
  4. It might require an EFI partition, but I am not really sure how to create one.

If it helps, my system is a Dell Latitude E7240 Ultrabook, and is fairly new (released in 2017).

Easiest/quickest way to get up and running would be to select use entire disk, automatic partitioning.

If you want to create your own custom partitions (and know what you are doing) I suggest booting Live into Gparted again to create them there (most reliable & common method used by Parrot users).

For those w/UEFI mode:
Create required EFI partition mount point /boot/efi. Make sure FAT32 type. Set boot & esp flags on that one. At least 512mb. Fat32 type is important to UEFI and holds boot loaders/firmware

Create other partitions to your liking.

Do not create a swap partition as newer btrfs file system does not support nor need swap partitions.

Like I said: quickest/easiest thing for you would be to do the use full disk automatic partitioning in the installer.

Let us know how everything goes :slight_smile:

I installed with automatic partitioning and was met with the Invalid Partition Table! error, but after booting live and flagging a boot partition, now I’m still met with the flashing underscore. Pressing enter does nothing, and I am set to Legacy with Secure Boot off.

I have absolutely no clue what I am doing so I’m not planning on making my own partitions anytime soon.

Your original partition table did not have UEFI’s required fat32 format EFI partition w/esp/boot flags. Most laptops after 2010 have UEFI. Not all brands/systems are the same. Sometimes we go through trial & error to get things running right, especially w/newer laptops.

What I did to install Parrot on 2019 laptop BIOS that was a bit troublesome to boot:

Set BIOS to UEFI w/Legacy Support. Secureboot turned off.

Booted Parrot live into Gparted.

Created my EFI partition at beginning of disk: formatted to FAT32 is important for UEFI. Enabled both esp & boot flags. Set mount point to /boot/efi.

Then created main Linux partitions (btrfs is what is used now, back then was ext4).

I then booted the installer and went through the installation process.

I swapped into UEFI and my laptop booted into the installer on its own. I didn’t need to create any partitions manually and as far as I can tell Parrot has installed fine, I just logged in for the first time now. Thanks for the help!

1 Like

glad to hear it’s working :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.