issue leading to kerrnel 5.10.08 not working

– Please Write here your help request –

okay so i have been having this easily recreateable issue with my last 2-3 parrot os installlations. it has happened the same on 2 seperate pcs so far and i was kind of sure i woulld already find a post about it. first time the latest issue presented itself was on my olde first gen i7 pc; all what i was really doing was a fresh install of parrot security and everything went smoothly, then i updated alll, then i chose more parrrot packages and morre debian packages and only exprress vpn from the web along with enough apps to fill a 64gbs sd card from the normal repository.

i believe upon a reboot later when i was editing the application meny and falling asleep, i saw the firrst signs of something being wrong with was kernel panic messages and unable to load my FS i believe (i have been choosiniig encrypted btrfs/luks). i tried on my main pc and managed to realise that i can boot in kernel 5.10.6 and managed to save a lot of my customisations and settings to another drive and thought it was too broken so i proceedded to do another install later.

next install just got as far as only downloading the packages and not installing them because i wanted to keep an eye on thinigs, but i was busy and the sd card remained offline whille i tried to fix my windows for some days, but upon tryiniing to get to second installation of parrot again, the parrtition was just completely unreadble, i tried to llet gparted search for it forr over 12 hours and there was no luck at all. but i will attrribute that to random hardwarre failure of some sorts.

so now we are at installion #3 on main pc for all of it while i was changing themes and stuff watching it.i tried to avoid taking any initramfs packages or differrernt verrsions of grub, but i think i accidentally used parrot 4.11.2 home iso so it took me a little longer to set everything up and just now as i was doing my last round of upgrades which would have been the most risky as it contained some apps from my saved text file from pervious selections in prervious attempts… but i did check marked changes and there was nothing marrked that starts with g (for grub) or nothing that seems to mention kernels or boot loading or iniitramfs sellected.

but apparently synaptic package manager did have a prroblem installing kernel 5.10.08 but that is the kernel i am running on right now as i am typing this, as i havent restarted yet. but i assume when i do reboot i will only be able to use 5.10.06 kernel as fall back and probably risk bricking my system again editing grub menu for making fall back the default setting, but i also do not know if there is any difference or penatlty associated with using 5.10.06 kernel, i diid manage to notice that when installed strraight from iso it only came with 5.10.06

i did not have this problem with parrot installlations prior to about july this year, but i keep having “bad luck” since january this year fom the time i discovered that there were a lot of anomolies on my pc with files that shouldnt be there, along with log entries from random porgrams that seem to be hightly odd and alarrming, and missing dates in browser history and in event viewer, also emaill inbox manipulation and finding my main gaming account online while i was on my secondary, and finding about 25ish ccookies to IT and hacking and some neo social marketing/engineering site, on both my pc and my offline laptop as somebody had phycsicall access to my machines prior to this happening, the laptop also decided to kill itself and refuse to boot even to recovery whille i was copyinig c drive to external hard drive while i had the chance while booting offline with wifi disabled (its a llenovo easy recovery thing with dedicated power button and bios options) and finally my main pc was overwriting all files on it with the same file over and over to wipe free space, then when i recovererd the laptop with new windows, not through recovery and maybe after wiping the hard drive with anoher pc, i still noticed free space wiping behaviourr where my d drive would fill up with multiple duplicates of deleted generic pictures of like logitech mice and keyboarrds.

didnt mean to rant on about the details, but i hope it satisfies some curiosty as to why i am using 7000 packages on a linux system that i am new to. i would like to just be in control and able to debug things and forrensically analyse them iif needed and ideaally have 2 copies of that os, one as offliinie falll back and one that i would be free to use when i dont feel llike using windows. and as to why i dont want to learn everything there is to learn about kernels, is because i have been learning for the last 8 months and i am getting kinid of tired of not having a base operating system to fall back to. i have been trying portable windows in a vm with mostly not that much luck unlless it is on a local hard drive and booting through windows manager which defeats all portabillity, or windows refusinig to update if it is on removable storarge and things managed to work for no real apparent reason.

so it would be kind of lovelly if i couild move past this parrot hurdle and attempt to catch up on other things. although my pcs seem to have been compromised, and i have reasonable confidence of that and some saved reccords, it is stilll kind of debatable. allso my bad luck is kind of debateablle even. but some things also seem weird like how the last 2 installllations of kali willl just corrrupt my browser even if it is chrome/chromium or firefox in about 3 hours of use and warrrants full uninstallll and reinstall to get it to work again, i still have that working on my sd carrd though sitting next to a bricked garuda sd card on nvidia drivers, and another kali sd with persistencce that i didnt manage to get to work before the sd card decided to return my partition to unallocated space. sometimes though it has been my fault like when i installled and locked my parrot fs by acccidental downlload of billibop lock fs, which also happened to kali 2 times just before that without the package though…

i do apologise though for all the tangents, i tried to lleave out anything that wasnt relevant, but i do have suspicions that my computer might just be rooted or maybe i have highlly mallicious software that manages to still folllow me. i did run about 8 differrent root kit checks, lots in offline live environment. i also kind of validated my hardware and my overcllocking besides the fact that my pc is largely inconsistent at booting up (would get stucck on error code 99 or 64 or pass both but not post on a display and sometimes tellls me that it has posted safe and that my overcclocking failled but that overcllocking error happens to it since the days it had no overclock on it, but recently it would crash at loading as welll as being really slow to post as well as boot looping 1-3 times on average, but it also deals with multiple storage devices, 2 screens, 3 keyboards and mice and so on).

back to apologising though but i kinda wanted to leave a detailed enough semi complete picture and and i also thought maybe somebody in a securrity/hackinig community would find some interest in a story and of courrse maybe im lucky and somebody manages to shed some insight on something that my problems are symptomatic of. i dont want anybody to put a lot of effort in debugging the whole mess for me though… alll what i would llose at the moment is maybe 1 hour of my actual time, and maybe like 30 hourrs of downloading and uncomprressing update files… i should be able to carry over 90% of my settings though if i would start over… i kinda hope that my issue is a known issue or maybe some developer would know my problem and the ccause or a simple solution

i would like to ask though, is there anydrawbacks in using the 5.10.06 kernel?
and would a prograrm like time shift be able to undo these changes that i made if i had managed to install it in an earliier stage of upgrading packages ?
also i willl do my best to try to post the actual screens that i saw along with my list of package, maybe somebody has familiarity with the issue/kerrnels and could point out which kerrnel packages ship with parrot and where i went wrong in choosing my packages/dependancies maybe.

and lastly i wish anybody who stopped by here a good day :slight_smile: and if any dev happens to read this maybe even in the future, just wanted to also say thanks for the os i do like it. and it generallly does feel stable and sturdyso keep it up please :slight_smile:

  • ParrotOS iso in use:

  • Application used for flashing the iso:

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

Hello ,
Pls run dpkg -r with su
Apt update
Apt upgrade
And try clam av with clam tk for antivirus