Issue with GUI after installation

Hello, i recently installed Parrot Security 4.6 by using a bootable usb key.
I’m using a dualboot with Parrot OS and windows 10 alongside.

So here is the problem, when i boot i get stuck on a black screen with “Wlan0: link is not ready”. And i can only access the shell by using ALT+ F2 but i don’t have any graphic interface. I tried updating the AMD Drivers but it doesn’t change anything.
Could anyone help me fixing this issue.


hi. you can try and see if parrot 4.7 fixes your issues.

I have the same problem you have and the worst thing that the pointer is static

Are you using laptop? What is name of AMD graphic card you are using?

Yes, i’m using a laptop. I actually use the chipset of my processor, it’s AMD Radeon Vega 8 Graphics. The CPU is a AMD Ryzen 5 3500u.

Please try this link:
P/s: have you checked the option 'nomodeset` or something like that in boot menu?

Sorry for my silence, i was really busy. So i just tried to create a new bootable usb key using Etcher and the 4.7 version of Parrot OS. I tried to boot using live version and i have a working GUI, i will try to install it to see if all is ok right now.

Thanks you for the help.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.