Issues Booting on Lenovo IdeaPad L340

Briefly describe your issue below:
I’ve been attempting to boot/install Parrot 4.6 for a week. Whether booting from a live media or from an installation I get a “AMD - VI: Unable to write to IOMMU perf counter” followed by a blank screen with a blinking cursor. Secure boot is disabled, I tried both UEFI and Legacy. I tried booting in recovery mode and I was able to get a terminal and confirm that the kernel isn’t completely broken. After many hours of surfing the web for any relevant issues, I’ve noticed plenty of others have issues with getting most linux distros to work on AMD Ryzen hardware. This makes sense considering I get no gpu and no network interface but I’m still able to actually use the system from the terminal. Is there a way to get Parrot to work with my hardware and if so, will it require me to compile the kernel myself? If that’s the case, I need to know what I need to configure when recompiling, etc. I’m determined to get Parrot to work on this laptop and I’m willing to spend all day (or several) to figure this out.

Any help with this is really appreciated. I’m trying to set up a dedicated Security/ Pen Testing PC and it’s the only reason I bought this thing.
What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64) Parrot 4.6 Security MATE amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) Both Debian Standard and GTK

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

try Parrot 4.7!
maybe this solve your problem

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.