Issues installing on Acer Aspire 10


New to Parrot OS. I fixed up an old Acer Aspire Switch 10 SW5-012, wiped Windows, and tried installing Parrot Home 4.6.

I used Etcher to create a bootable USB with the iso and the installation seemed to go well.

After installation, I was faced with “No Bootable Device”.

I thought it might be an issue with grub, booted live, and tried to follow the community tutorial to install grub (Tutorial installing grub using live usb).

Though the live boot worked well, I couldn’t get the tutorial to work for me. After looking at my issue again, I came to understand that though the aspire 10 has a 64-bit Intel Atom CPU, it has 32-bit UEFI firmware.

Not sure how to get a 32-bit UEFI bootloader, if that would even solve my issue, or if there are some other problems in installation or when trying to fix things.

If installing 4.6 is a dead end on this acer, would it be advisable to try Parrot-home-4.4_i386.iso?

Thanks in advance

What version of Parrot are you running? Parrot Home 4.6

What method did you use to install Parrot? GTK Installer

Configured to multiboot with other systems? No

If there are any similar issues or solutions, link to them below:

u need to mess with your bios and the bootloader. refind will help you

and/or maybe you find something in here:

dunno if you can make the 32 bit uefi read your 64bit os with this, but yea, installing the 32bit version of parrot would “fix” your problem too without messing around…

here is another read:

1 Like

Hey, please check that out, Acer has specific boot settings.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.