Issues with OpenVPN, gdebi, etc

Hey so I’m pretty new to Linux and i’m using it for defence purposes.
I run
openvpn --config mullvad_us.conf
and then I get this, but nothing else ever loads and its stuck like this.
Sun Aug 5 00:31:36 2018 Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore. Sun Aug 5 00:31:36 2018 OpenVPN 2.4.5 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Mar 4 2018 Sun Aug 5 00:31:36 2018 library versions: OpenSSL 1.1.0h 27 Mar 2018, LZO 2.10 Sun Aug 5 00:31:36 2018 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

I also had an issue where I’d try installing the client version of mullvad (vpn provider) instead and I get an issue whilst running
gdebi mullvad_67-1_all.deb
Dependency is not satisfiable: python-appindicator

I’d also like to know what I can do in the future to stop these errors and install repositories & find repositories needed to fix errors like package not found & etc.

What version of Parrot are you running? 4.16.0-parrot12-amd64 GNU/Linux

What method did you use to install Parrot? boot from usb & install to harddrive

Configured to multiboot with other systems? no

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

install .deb file with dpkg
sudo dpkg -i mullvad_67-1_all.deb

based on github, you need
sudo apt install gcc libssl-dev libappindactor1

This is not an error, so it need to run properly.

any idea why it’s openvpn is not running properly? it worked on kali & ubuntu just not here

and also:
E: Unable to locate package libappindactor1

is there a way I can use packages from Ubuntu instead like somehow because I’m pretty sure it only uses packages from the parrot OS am i right?

So, i tested mullvad’s vpn.
For me it is run properly.
Downloaded the config file, with these settings:

unzipped it
move to the unzipped folder
there is need to be 5 file: crt, pem, conf, userpass.txt and update-resolv-conf
not writed down the full name of files)
then the command is:
sudo openvpn --config mullvad_XX.conf

If you see Initialization Sequence Completed, then you are connected to the vpn

that worked for some reason I was doing everything exactly the same except I put it in the openvpn folder instead. I was trying to run from a folder called mullvad on my desktop,

Although one more question just because I am new to linux and stuff and it would really help to know this , when I get errors like this:
E: Unable to locate package libappindactor1
what is the best way to fix & install the package? and how do packages work , where does the computer look to install and find the packages? just curious and knowing this would really help me.

thank you so much you’re a great help.

Now i know your problem. If you open the conf file, you can see the this:

The openvpn search for this file in the folder where your terminal is in, because there is no absolute path for the files.

When you need packages first search in the parrot’s repo:
apt search libappindicator1

If there is a result, install it with apt:
sudo apt install libappindicator1

Please read about how apt work, and if you want to upgrade your system use dist-upgrade :slight_smile:

I’ve found out you typed it wrong. It is libappindicator1 and i found it on the Debian repository ( I am using Debian 9 now) so Parrot OS should have this lib on repository.

Hi g0rbe,
I saw your response on the thread while searching for this issue.

I have been having similar issues as the OP. I cannot get mullvad to work properly via importing the config file to the Network Manager. Mullvad’s instructions show to build a ‘Android’ config file.

I also tried your instructions on this post, using the same server and port as your test, moved the extracted files to /etc/openvpn, but get the following error when I run the command from there:

$sudo openvpn --config mullvad_ca.conf
Tue Oct 16 21:06:26 2018 Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore.
Options error: --up script fails with '/etc/openvpn/update-resolv-conf': Permission denied (errno=13)
Options error: Please correct this error.
Use --help for more information.

Any ideas? Thank you in advance!

For me, its working.
Check the permission of /etc/openvpn/update-resolv-conf:

ls -l /etc/openvpn/update-resolv-conf

Hi G0rbe,

It looks like the permissions are for root read/write.

    $ls -l /etc/openvpn/update-resolv-conf
-rw-r--r-- 1 root root 1301 Oct 16 21:17 /etc/openvpn/update-resolv-conf

I tried to update permissions to include execute but I got an error that the operation was not permitted.

    $chmod u+wrx update-resolv-conf
chmod: changing permissions of 'update-resolv-conf': Operation not permitted

Update: I neglected to execute the command with sudo. I tried again and that added the execute permission, and now it will allow initiating the vpn from the command line. Thank you!!

However - turning on the VPN from the network manager GUI still does not work. :frowning:

1 Like

Is that because network manager isnt being run as root?