Java installation problem

I tried to install OpenJDK 8 on Parrotsec but it is showing that’s it is already on a new version but when I tried to config it’s showing me this

There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/java-10-openjdk-amd64/bin/java nothing to configure

and it is showing java 10 version.

I installed NetBeans and it’s not opening. Maybe it was NetBeans 8.2 and Java 10 doesn’t support this version. So what I can do?

I also tried to install Oracle JDK but it is showing me permission denied. Help needed.

What version of Parrot are you running? Parrotsec os 4.2 (Security edition)

What method did you use to install Parrot? Debian GTK

Configured to multiboot with other systems? no!


Yeah java 8 should be installed, you can use sudo update-alternatives --config java you can change the default java version.
Netbeans might not be opening because of firejail. Use firejail --noprofile netbeans and see if that works.

Thank you for reply! I solved that issue. Parrotsec telegram group helped me a lot. <3

1 Like