Kernel Panic After Update

(Piero Khorkni) #1

Briefly describe your issue below:

What version of Parrot are you running? (Parrot GNU GRUB version 2.02+dfsg1-8parrot1. 64-bit)

What method did you use to install Parrot? (Debian Standard)

Configured to multiboot with other systems? (yes)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

The above screenshots show the current state of my Parrot System.
I use Virtual Box.
This error happened after I updated my parrot system. I shut it down then tried to boot it again and I was greeted with the messages above!

Any help will be appreciated.

Thanks

#2

what is your host system?

How did you upgrade?

(Nico Paul) #3

Large flock here.

(Piero Khorkni) #4

My host system is MacOS.

I updated by clicking on the pop up window that asks you if you want to update your system (via the command line)

(Amzker Pro Hacker) #5

Just edit Grub and set full path for kernel

1 Like
(Piero Khorkni) #6

Thanks for your help! But the thing is when I choose one of the options in the screen below

I get the following message. When I get this message, any input from the keyboard isn’t recognised!

#7

have you tried searching for these errors? theres a reason why it’s unable to mount the rootfs. I would check virtual box forums as well. currently you have way too many kernels in grub from the first photo you have from 16 to 19 which is insane. might be faster to live boot from an iso and clean your grub and replace the kernel

(Enrique) #8

As Amzker says, you just need to edit grub to latest kernel.

If your grub shows up when you boot to your system go to advance (Where recovery modes are). Based on your evidence, your latest kernel version is the 13t, so all you need is boot in recovery mode but for the previous kernel version (10 in your case).
Type your root password if needed and then follow this commands:

#mount -o remount,rw /
#\

mount -o remount,rw /
#mkinitramfs -o /boot/initrd.img-4.19.0-parrot1-13t-amd64 4.19.0-parrot1-13t-amd64 (Hope no errors here, no output is shown though)

Then just update grub and grub2
#update-grub
#update-grub2

Then reboot with #reboot and your parrot os should start as expected.

Regards,

(Piero Khorkni) #9

Hi, thanks all and thanks very much @ Kikeman for your beautifully detailed solution.

Regards,

closed #10

Solution found