kismet running cpu at 100%

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
  3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release

     ```
     Copy output here
    

DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.10
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION=“Parrot 4.10”
PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.10”
VERSION_ID=“4.10”
HOME_URL=“https://www.parrotsec.org/
SUPPORT_URL=“https://community.parrotsec.org/
BUG_REPORT_URL=“https://community.parrotsec.org/

    ```
  • Kernel version: run uname -a
    Copy output here Linux parrot 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.10
Desktop Environment: Mate
Edition: Security

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?

    • Software was used to make USB
    • Steps of making USB bootable
  2. How did you install OS?

    • Debian installer or Calamares installer
      Debian

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
```
    Copy output here
```
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

Yes

4. How did you get this error? Are there any steps to procedure it?

1. I installed this
2. I ran this new software
3. It shows me this or that

This happened after most recent update

5. Error log or screenshot

** Insert error log and screenshot here**
/home/ryz/Pictures/Screenshot at 2020-09-26 19-20-15.jpg

6. If you have any idea or suggestion about this issue please tell us

** Your information **
After the most recent update one of my CPU cores is running at 100% constantly and
the culprit is obviously KISMET. I have tried looking for ways of disabling it but have found
only installation and launching info. My attempts at disabling it or more specifically the
kismet --no-ncurses-wrapper in the terminal don’t work. Also worth mentioning that I did not
at any point alter any settings or config file for KISMET on my own. Also can’t figure out how to
disable KISMET at startup and then deal with config issues as I don’t want to melt down my CPU
while tinkering with this problem. Any help would be much
appreciated as obviously this makes Parrot pretty unusable.

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea

On my initial post I had booted into an alternate kernel to see if that fixed the problem, it obviously
didn’t. The current updated kernel is:

Linux parrot 5.8.0-1parrot1-amd64 #1 SMP Debian 5.8.7-1parrot1 (2020-09-14) x86_64 GNU/Linux

although it really doesn’t matter. Also, here is the intended screenshot from above:

The mistake I was making was trying to type in

kismet --no-console-wrapper (trying to issue commands directly to kismet)
and getting a basic ‘NO’ response from the system while trying to shut it down that
way. because I was stressed about one of the cores running at 100% I managed to
forget about something as simple as ‘systemctl stop kismet’ as a command that absolutely
does kill it. That’s partially good news. The bad news is that today’s update (to kismet) didn’t change
anything and if I want to run Parrot it won’t have kismet running until I can figure out what
ridiculous thing happened. I’m also going to have to evaluate my level of concern for this.
I stopped using Parrot as a daily driver back in early April after an update caused massive problems
on a laptop it was installed on. I installed a different Linux distro on it and haven’t had issues
since. So Parrot only exists on one secondary HDD on a desktop computer in a spare bedroom.
I’ve asked 4, maybe 5 questions in one year of using Parrot on this forum and never had any
response of any kind, so I do know that I’m talking to myself here. But just typing this is helping
me think more objectively about what I’m doing with the computers I have and what needs to
change. At least I now have the option of looking through .conf files and logs and whatnot without
damaging my processor (or shortening the life of it dramatically). BTW-- I’m in no way fishing for
a response by typing what I did above; the silence is cathartic and beneficial at this point. Not
complaining at all.

1 Like