Latest Parrot-Upgrade Removes Firefox

$uname -r

I just did a parrot-upgrade which removed Firefox 89.x, including bookmarks, extensions, etc.

Firefox 78.15.0esr is installed, but how can I import all my lost stuff from
/home/user/.mozilla/firefox/5uxhzsou.default-release into /home/amen/.mozilla/firefox/8slqn8n1.default-esr? Why was Firefox removed and will it return?

I’m pretty upset. Thanks.


Agreed. Frustrated that I cannot seem to get to my bookmarks or saved passwords.

Anyone have any solutions?

Hey Guys,

I figured it out. I have to go to work so I am typing this quickly. I apologize in advance for any lack of detail. If you need additional help I will log on later today.

  1. Create new ff profile to open browser.
  2. find your ff profile folder. [mine = /home/commons/.mozilla/firefox]
  • you should see your old and new profiles.
  1. find the ‘bookmarksbackup’ in your old profile. Copy that to the same folder int he new profile.
  2. You will need to open the bookmark library and click [ settings ‘library’ > ‘bookmarks’ > ‘show all bookmarks’ > ‘import and backup’ > ‘restore’] here you should see the file you copied into the new profile.
  3. The extensions I copied directly from one folder to the other

I haven’t done everything yet, but I got the bookmarks and extensions back in the new profile I made.

This page has some other useful info about ff file locations.

Hope this helps! sorry it is light on detail but I have to run. Let me know if you have questions I will be back on later today.


1 Like

Thanks! That worked. Still lost some stuff like my NoScript settings for various websites, logins, homepages, etc.

Pretty new with Parrot.
I can not sync Firefox. My additions, bookmarks have disappeared.

Do not understand the description above.

The above only copies your bookmarks and plugins over to a new profile… not a fix as it is still running the older Firefox version from ESR. Looks like Debian dropped support for mainline Firefox and went ESR. You could just add a repo for the mainline version.

This won’t work though due to unmet dependencies…

1 Like

Rather than delve into dependency hell. If you find the compatibility.ini in ~/.mozilla/firefox and delete out line LastVersion=xxx then the old profile should load with ESR till this gets sorted.

Another way to work around this is using the firefox appimage:

All right… the same thing happened to me. Firefox just disappeared after a full upgrade. Very frustrating. Then I installed esr with the package manager, restarted and there it was again. I am putting myself to bed, now.

Hello !
So, i install chromium and use, Version 90.0.4430.212 (Developer Build) built on Debian 11.0, running on Debian parrot (64-bit)…firefox esr is old version ! I search brave*.deb or opera*.deb on debian 11 and mayby after install be run…

Just fell foul of this Firefox shit, would have been nice if we got a warning before the upgrade :frowning: Lucky enough I have 2 laptops that setup the same so just copied bookmarks from there :slight_smile:

Glad you had a backup handy!

I alternate between sudo parrot-upgrade and using Synaptic to do my updates. I wonder if Debian would have had a Change-Log (warning and explaining) in Synaptic before uninstalling Firefox Release 89.x? I already had Firefox-ESR installed, but hadn’t launched it until Firefox Release was ~forcefully~ uninstalled.

I just did an daily update using Synaptic and while I’m upgraded to a new kernel (5.14.9-9parrot1) and a few other packages, it downgraded my virtualbox-dkms and qemu packages.

Yeah, annoying for sure, but at least it was not super impactful. I was concerned that I would lose everything. Once I figured out where each of the items [passwords, extensions, extension preferences, user settings, bookmarks] were I just copied them over to the newly created profile and I’m back to where I was before the upgrade.

Frustrating - yes. But really very little lasting impact.

If anyone is having trouble recovering let me know - I will try to provide more detailed instructions on how I recovered all my firefox items.

Hey there,
the firefox removal also happened to me.

uname -r

I would not like to be forced to switch to the firefox esr version.

Did the usual firefox version got removed accidentally or on purpose? I think when I tried to install it again apt returned something like “no installation candidate”.

Happy for any reply!
Have a nice Sunday.

we had mainline firefox before, but it was made unavailable for debian stable (and testing), so we had to remove firefox amd replace it with firefox-esr instead, which is the stable and LTS version of firefox

You can install latest version firefox from snap


thank you! I appreciate your response :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.