Lenovo t450 doesn't work with parrot security

Hi all,
I used for some months the “home edition of ParrotOS”, after it I decided to clean up my laptop and bring him new life with the "security version of ParrotOS’ but I really can’t understand why doesn’t work.

I don’t have any other system in dual boot, i tried all the possible combinations ( tried LVM encrypted, not LVM, without encryption ) and all the time that i booted the system i had the same problem… without the acpi off i can’t arrive to the login but I can only unlock the disk if encrypted and after it I reach a black screen with an arrow and the trackpad that don’t work. With the acpi off at least, I can boot and login, but when I try to suspend the pc or turn it off it will freeze and you can only turn it off from the power button. Also, the function keys on the keyboard don’t work and I really can’t understand why if with the home edition I didn’t had any kind of problems.

Someone have my same problem?


Aloha mate,

I had similar problems with a new thinkpad E495.

Still don’t have a solution for this. I switched to Parrot and it works…

Let me know if you found a solution.

I already posted this 1 week ago in the kali forum, still no reply / answer / idea from no one…

" Angry Lenovo Thinkpad E495 + Kali Linux 2019.4 = Display not working

I just received my E495 Thinkpad with ryzen 5 cpu and I keep on ending up with the same problem.
I can install Kali without any issues. Then, when I boot into Kali everything seems fine but then, when booting into Kali from the second time on, my display goes crazy. I can boot into Kali until the Log in screen shows up. After signing in the Display just stays black or sometimes the Kali OS is displayed but the display doesn’t work right. When I open a tab for example, the tab has all kinds of colors in it. When I move the tab with my mouse the tab changes colors and I can read what’s inside the tab.

I tried formatting and partitioning my build in ssd, I tried to install Kali without any other Win OS, I disconnected all USB devices, I don’t know what to try else than this.

Any ideas?


If you had Home Edition installed & working properly there might be something missing here. There really shouldn’t be a difference in compatability between Home & Security versions. One just has a different set of packages.

First, and most importantly: How did you burn your copy of Parrot Security Edition? Only dd command & Etcher are suggested according to the Official Parrot Docs. Other options may burn an incompatible disk that may fail at certain points of installation/boot.

If you are sure you followed all instructions properly? Did you install from the boot option… or did you try to install from inside a live booted session? It is recommended IME to install outside of the live boot session.

If you are indeed using the same exact laptop that successfully installed/booted Home Edition of Parrot, I would take a closer look at bios settings & the installation procedure you chose.

Generally speaking, Lenovo laptops are quite Linux compatible.

You could try this tested method next install:

Enable any Legacy support options BIOS offers
Turn off SecureBoot in BIOS
Turn off Intel’s RST mode & instead Turn on AHCI mode
Try a full disk install (if you don’t require dual boot)

Most importantly, 1st make sure to burn using dd or Etcher to root out the most common issue: a bad copy

  • Your ffellow Lenovo owner

I tried some different things and finally I found that I can replicate the same problem also with the home edition. So after all the night of frustration I didn’t use the laptop for the whole day and the the day after I could no longer replicate the problem and installed the security version without any issue. I really can’t understand how or why… also because i also didn’t changed anything… i didn’t burned a new iso on the usb or changed the usb key… nothing was changed so… I really can’t figured it out how but I am actually using my parrot security installation on my Lenovo and work like a charm

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.