Lenovo ThinkBook 15 20RW. Touchpad not working

Seams like it does not even recognize that I got a *touchpad. Mouse still works. Tried updating the whole system, no effect

*Version. 4.9), Parrot Security MATE ISO (default), and architecture (64-bit, if that is what you ask ^^)

What method did you use to install Parrot? (Debian Standard with USB)

Configured to multiboot with other systems? (no)

If there are any similar issues or solutions, link to them below:


Mouse still works but yet seems like system does not even recognize you have a mousepad?

Please be more clear in questions in order for us to help you.

If you mean your mouse is not working on parrot but is on other systems you may need to find the Linux driver (if one exists).

When I plug in a mouse it works. But the *touchpad on Laptop is dead, no clicking, no moving. Clueless as to fix it. Must add that I am new to Linux (yes I start as a script kitty, but you gotta start somewhere). With version 4,9 and updated it should be newest version(?)

have you tried to install the touchpad drivers manually?

My Lenovo Ideapad has a touchpad toggle/disabler as one of its Fx keys(F6 in my case), perhaps your’s does as well. If its not working with anything make sure the hardware isn’t damaged or unsecured/disconnected internally (that involves taking the laptop apart).

Sadly it had no effect. As for it being damaged. It is less than a week since I bought it, same day as it got available. If I got a damaged product I will demand a refund. When I type -sudo cat /proc/bus/input/devices I don’t see the text touchpad anywhere. Guess some driver is missing. Sadly I am new to Linux, you got to start somewhere :confused:

Have tried the following without result and starting to give up.

sudo nano /etc/default/grub
and added i8042.reset to the grubline (with and without adding splash that some had) with sudo update-grub no effect

Sudo cat /proc/bus/input/devices
under N it says “HDA Intel PCH HDMI/DP,pcm=10”

Gone to synaptic package handler and installed the touchpad package.

sudo parrot-upgrade and upgraded as recent as today.

F6 can switch touch on and off, but doesn’t make any difference

Even tried an apt-upgrade in desperation which appears to have given a bug
sudo apt-install xserver-xorg-input-synaptics

I will reinstall Parrot OS and simply use sudo parrot-upgrade. I guess it is a compatibility issue? Might try with ArchLinux and see how that works
Edit: Reboot made sudo parrot-upgrade work as usual
But still unless there is any other solution I think trying other distros is the best option for me :confused:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.