LibreOffice doesn't work!

Hello!
I could use some help, LibreOffice doesn’t open anymore!
I am using Parrot Security Edition with Mate.
It’s a new installation, the old one worked perfectly but now I don’t understand!

This is the error message:
Reading profile /etc/firejail/libreoffice.profile
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-passwdmgr.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/whitelist-var-common.inc
Parent pid 8288, child pid 8289
Blacklist violations are logged to syslog
Child process initialized in 59.28 ms
Final linking of kernel DynamicKernel failed.

MANY THANKS !

OK!

What version of Parrot are you running? (include version (e.g. 4.5), edition(e.g. Home), and architecture (currently we only support amd64)
Parrot-security-4.6_amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian GTK-GUI

Configured to multiboot with other systems? (yes / no)

no (I hate windows :grimacing:)

If there are any error messages or relevant logs, post them below:
Reading profile /etc/firejail/libreoffice.profile
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-passwdmgr.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/whitelist-var-common.inc
Parent pid 8288, child pid 8289
Blacklist violations are logged to syslog
Child process initialized in 59.28 ms
Final linking of kernel DynamicKernel failed.

Well…
I reinstalled the system and it seems to work better all of a sudden!
I don’t know what it was due to, but now it’s settled!

Thanks to the whole team, you are doing a good job !

Run which libreoffice
if output is /usr/local/bin/libreoffice, then do
ls -la /usr/local/bin/libreoffice
if the output show you the file is a link file points to firejail, remove it, and your libreoffice will work

are you saying remove the libreoffice file from the `/usr/local/bin/bin’ dir?

ls -la /usr/local/bin/libreoffice
lrwxrwxrwx 1 root staff 17 May 28 14:26 /usr/local/bin/libreoffice -> /usr/bin/firejail

or maybe Replacing the sed line with readlink?

No just remove it. The actual libreoffice path is /usr/bin/libreoffice

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.