Lightdm : Fail to start (not a VM)

Briefly describe your issue below:

Hi there,
when I check systemctl status lightdm, I have an error:
lightdm.service: Failed to enqueue OnFailure= job: No such file or directory

There are others topics (see below) treating this issues but it’s not a Virtual Machine, it’s on my physical one.
I have indeed virtualbox installed.
I tried to :

  • install last vbox additions from the iso => Same problem
  • apt purge virtualbox => Same problem

What version of Parrot are you running? (include version, edition, and architecture) : Parrot 4.0 kernel 4.16.0-parrot5-amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) : iso version 3.8, then update, full-upgrade

Configured to multiboot with other systems? (yes / no) : no

If there are any similar issues or solutions, link to them below: :


My solution was to open shell when booting , and install parrot-xfce. Then I could boot mate desktop no problem. I also removed xfce from system and still no problem.
Surely some one has a easier fix for lightdm