Live USB doesn't connect to wifi

Have tried using both the Home Parrot 4.11.2 XFCE amd64 & Security Parrot 4.11.2 amd 64 ISOs to make a live USB with etcher & antiX Live USB maker, & dd command from the terminal (for a total of six attempts). I have also tried each of those attempts on two different laptops, HP NoteBook with an Intel 7260 wireless wireless, & a HP EliteBook with a Centrino Advanced-N 6205 wireless interface. In all cases I was unable to connect to the internet, though the icon in the system tray seemed to show I was connected.

The installed OS on each laptop was antiX 19.4 with 5.10 Kernel, both of these have no problem connecting to the internet. I also verified with three other live USBs, with Kodachi, Predator, & antix 19.4 installed on them, all three of which could also connect to the internet.
Also, I temporarily had Parrot Home made from the same Iso that I made the live USB from, installed on my HP Notebook & had no problem connecting to wifi.


  • ParrotOS iso in use:

  • Application used for flashing the iso:
    Etcher, antiX Live USB maker, dd command from the terminal

  • Logs/Terminal output (use pastebin or similar services):
    I only made the first USB persistent, but once I noticed the problem, I wrote over the USB in to try again. All the following USBs were made without persistence, as I was focusing on the problem connecting to wifi. So there are no logs.

  • Screenshots:
    Same answer as above for logs/terminal outputs.

MATE is best imho

dd if=Parrot-security-4.11.2_amd64.iso of=/dev/sdX bs=4M

is what i use to create my live iso’s and it works everytime

once your on the parrot desktop, usually connect to your internet top right ?

1 Like

That’s exactly what I did when I referred to the dd command , & was unable to connect to the internet.

what interface are you using to connect to the internet ?

I use both parrotOs and kali linux, just read in this link, this is problem solving from kali linux official website easy to follow:

Troubleshooting - Wireless Cards