Login loop

Briefly describe your issue below:

I am having an issue at the main login screen, it installed just fine but i cant login despite having the correct password.
I am running version 4.2.2 i am not dual booting it is a standalone system on a desktop. I used a usb boot device to install.

What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Have you tried logging in to the console?
ctrl + alt + f1
Try and log in there. (ctrl + alt + f7 to get back to the gui)


Had this issue today actually
Carried out the following steps

#Get to the command line

  1. ctrl + alt + f1
  2. log in using your normal username and password

#Change some permissions

  1. sudo Chown $USER:$USER .Xauthority

#Back to the GUI!

  1. ctrl + alt + f7
  2. select your username
  3. Login!

Welcome back to the desktop screen of Parrot OS.

1 Like

This is easy to fix. Apply following command how root in account that have this issue.
The cause is .Xautority was write improperly.

ctrl + alt + f4
use root credentials to login in black terminal

#rm file in /home/your-user-account-with-error/.Xautority
Not have fear, the system will be create an new file .Xautority writed correctly in next boot.

in black terminal #exit and ctrl+alt+del the system will be do reboot. Now do login normaly

Iā€™m using my Parrot now, after fixed in this mode, in the same session. Be happy!

i would also like to add that this could occur as a cause of full space on hardisk as i just encountered if you harddisk is full just clear it and delete the .Xauthority file and your problem should be fixed

I also, have a similar issue, I deleted the .xAuthority file, reinstalled lightdm and xorg but nothing helps, after entering password it tries to load main screen but comes back to login screen, I even created other account to login, but this happens with them too

Hey i am having the same issue did U Found the Answer yet

I was also having some problem but i fixed it by moving Xauthority file.

To fix this follow this steps:-

1.Press Ctrl+alt+F1 to open login terminal

  1. After login Type :- mv .Xauthority .Xauthority.bal

3 . Press Ctrl+alt+F7

4.Type your password

I hope this can fix