Lost KDE-Desktop, can't copy files to USB pen drive

I lost KDE desktop trying to upgrade,
I’ve been using Parrot OS (KDE Version) for over a year now, in dual boot with Windows 10.
I started using Parrot OS to learn ethical haking, but with time I lost interest in haking, but still loved the parrot OS theme and graphics, so 3 days before today, I installed Parrot OS (I used ‘Parrot-kde-security-4.6_amd64.iso’ file) to be the only OS on my laptop and moved all my files into it.
Then I tried to upgrade it using
Sudo parrot-upgrade
Which kept giving an error about a ‘rolling version’ and a ‘public key’.

  1. So I searched the web and found this to solve the ‘public key’ error,
    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys # the PUBLIC KEY was here

  2. But it gave me a new error about a package, so I used this,
    sudo apt install gcc-8-base

  3. then I used the usual command,
    Sudo parrot-upgrade
    Which gave me a new error,
    It was 3am in the night and I don’t think I was in my best consciousness,
    I read the error and saw the command to remove unnecessary packages,
    Which I did indeed use (I know, I shouldn’t be awake, this late…)-: ,
    but then around 80% of the process completion, I saw the wifi connection disappear, and I couldn’t access folders anymore, it was like a nightmare, I panicked and quickly switched off the laptop from power button.
    Then I switched it on again and it’s only a small terminal on the top left corner of desktop.
    I tried these commands,
    Sudo apt-get install plasma-desktop
    Sudo apt-get install plasma-workspace
    Sudo apt-get update --fix-missing

They don’t work, I think there is no connection to the internet, even when I used a cable to connect with the router.

I tried to copy files from parrot to my pendrive, but then again, I can’t see the pendrive listed in ‘/media’.

Now I’m hoping to go with this,
"If you nuked Network Manager too (or it doesn’t work) I think I would fall back to chrooting your install from within a LiveCD (with a working network connection).

Boot to the LiveCD (Select Try Ubuntu).
Set up a network connection like you normally would.

Open a terminal and run sudo fdisk -l and note the /dev/sdX# name of your install’s partition. In this example I assume /dev/sda1.

Mount it with sudo mount /dev/sda1 /mnt — If you have mounted it as something else (eg if you used Nautilus and it mounted as /media/ubuntu/…) you need to replace /mnt in the following two commands with its actual mount point.

Cross-mount various system things:
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
Chroot in: sudo chroot /mnt. You are now root on your old install.

Once you’re connected, Just run:
sudo apt-get install ubuntu-desktop"

I have a dozen valuable files in the hard drive and I need to get them out, I’m sure if I do get them out, I won’t ever touch parrot OS again, somethings ask for whole another level of intelligence. Please help!

you followed the wrong tutorial
its for ubuntu and though some tutorials of ubuntu work on Parrot System but not everything is same.

if you are able to boot into the tty1 terminal, you can do a simple ping to check whether the internet connection is active or not (With ethernet). To do that just do,
````ping -c 4 www.google.comafter that, if internet is working dosudo parrot-upgrade and thensudo apt install parrot-kde```
this will install the kde back

‘ping: www.google.com: Temporary failure in name resolution’

what about
ping -c 4

‘connect: Network is unreachable’

This helped me to copy the files out.