LTE EM7345 stopped working

Briefly describe your issue below:
LTE EM7345 is not working. (Lenovo ThinkPad T440p)
I installed ParrotOS 10 days ago and when I first logged in, it was asking the PIN code for SIM card, (which unfortunately I didn’t test at that point) but was working.
4 days ago, I enabled the Mobile Broadband but nothing happened…
I don’t know at which point stopped working since I wasn’t using it.
The SIM is in place, and works perfectly fine.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot 4.7, Security, x64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
no

List your hardware specs to include make, model and firmware (when applicable):

└──╼ $mmcli -m 0
  -----------------------------
  General  |         dbus path: /org/freedesktop/ModemManager1/Modem/0
           |         device id: c--------------------------------------5
  -----------------------------
  Hardware |      manufacturer: Sierra Wireless Inc.
           |             model: Sierra Wireless EM7345 4G LTE
           | firmware revision: V1.1,00
           |         supported: gsm-umts, lte
           |           current: gsm-umts, lte
           |      equipment id: 0--------------
  -----------------------------
  System   |            device: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-10
           |           drivers: cdc_acm, cdc_ncm
           |            plugin: Generic
           |      primary port: ttyACM0
           |             ports: ttyACM0 (at), usb0 (net)
  -----------------------------
  Status   |             state: failed
           |     failed reason: sim-missing
           |       power state: low
           |    signal quality: 0% (cached)
  -----------------------------
  Modes    |         supported: allowed: 2g, 3g, 4g; preferred: none
           |           current: allowed: any; preferred: none

If there are any similar issues or solutions, link to them below:
Possibly related with this issue
https://community.parrotlinux.org/t/lte-em7455-stopped-working-after-parrot-upgrade/10268

If there are any error messages or relevant logs, post them below:

└──╼ $sudo mmcli -m 0 --enable
error: couldn't enable the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.WrongState: modem in failed state'

Oct 17 12:06:35 parrot NetworkManager[853]: <info>  [1571303195.9224] modem-manager: ModemManager available

Oct 17 12:06:41 parrot NetworkManager[853]: [1571303201.5332] manager: startup complete
Oct 17 12:06:45 parrot NetworkManager[853]: [1571303205.1701] device (usb0): state change: unavailable -> unmanaged (reason ‘removed’, sys-iface-state: ‘removed’)
Oct 17 12:06:45 parrot NetworkManager[853]: [1571303205.1721] device (ttyACM0): state change: unmanaged -> unavailable (reason ‘none’, sys-iface-state: ‘external’)
Oct 17 12:06:45 parrot NetworkManager[853]: [1571303205.1723] device (ttyACM0): modem state ‘failed’
Oct 17 12:06:45 parrot NetworkManager[853]: [1571303205.1727] manager: (ttyACM0): new Broadband device (/org/freedesktop/NetworkManager/Devices/5)
Oct 17 12:06:45 parrot NetworkManager[853]: [1571303205.1735] modem-broadband[ttyACM0]: failed to retrieve SIM object: No SIM object available

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.