Monitor mode not supported

Briefly describe your issue below:
I have an Archer T4U v3 with the 8812au chipset. It’s supposed to support monitor mode (I checked a few sites) but I can’t get it to work. I used different methods (iwconf and airmon); I looked it up on the internet and couldn’t find a fix to why it doesn’t work.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.7 security version
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
It runs on a VM
Configured to multiboot with other systems? (yes / no)

List your networking hardware (make, model, firmware version):
Archer T4U v3 ac1300 // rtl8812AU
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Are you sure that the adapter uses the the 8812au chipset and that you have the driver pkg installed? I did a little digging and it doesn’t appear to be using that chipset but in the event I’m wrong(I may very well be), is the VM configured properly to allow for access to usb devices?

Thank you for your quick response.
Well…no. The one provided on the TP Link website is the rtl8822bu. I installed that driver first but it didn’t work either. I could connect to wifi through my wifi card and the card was working well, I just didn’t have access to monitor mode. So I looked it up on the internet and found this website ( which list the same adapter as mine but with a different chipset apparently, so I installed those drivers (on a new VM) and same as before my card was detected as wlan0 but could not be turned into monitor mode.
I don’t think it’s USB related as it’s detected fine and working but I might be wrong ?

Edit 1: Might be a really stupid question, but I’m a total newbie. Is it possible to put my adapter into monitor mode via windows ? As it’s working fine on windows, I could be able to see if it’s driver related or not.
Edit 2: Tried and couldn’t put it in monitor mode, must be the wifi card itself… Which is strange because it’s suposed to work fine… Might just buy a new one and see if it works. Any suggestions ?

  1. Manufacturer knows best if they provide a 8822bu driver then that is the driver anyone else is mistaken.
  2. Not all drivers, most actually, don’t support monitor mode. The rtl882bu has no known monitor mode capable driver, someone will have to create one. On a related note the driver provided by the vendor, like one you might find on their website, never support monitor mode with rare exceptions.
    3.Yes I think monitor mode is available in windows with some tweaks as there is a version of Aircrack for windows I believe but its not supported by default…will have to check on that but it’s irrelavent in this case.
  3. What you need is a device with a chipset that has a monitor mode supporting driver. There are tons of guides everywhere so you can research that yourself. My purchasing advise is browse based on the chipset, whatever model name the manufacturer gives it doesn’t matter in the slightest. More expensive does not equal better.

Quick update :
I started a new VM and tried again with the rtl8822bu( from github and it’s supposed to support monitor mode) but followed this method:

vi ./Makefile
“CONFIG_80211W = n” ==> “CONFIG_80211W = y”

Everything went fine, I rebooted my system, and tried the “airmon-ng start wlan0” cmd // didn’t work. That was sad but expected :wink: BUT when I tried the “iwconfig wlan0 mode monitor”, it worked.
Well kinda… The output of “iwconfig” is still wlan0 (not wlan0mon or whatever) but it says mode: Monitor.
Obviously no wireless testing tools requiring monitor mode is working… I’m lost.

I believe the makefile sets up the modes for your driver. iwconfig then sets the interface modes based on your driver capabilities. Airmon sets up a virtual device if your primary has monitoring capability.
Thats the way I understand it anyway. I run 2 netgear USB adapaters and my primary is intel chip on a dell xps.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.