Most recent update broke Parrot boot

A couple of days ago I got a notification for updates, so I went ahead and ran them. After the updates, I noticed that my two finger scrolling went from reversed back to normal. “That’s weird.” I went to the touchpad settings and reversed scrolling was still checked, so I unchecked and checked again. Hmm…still not reversed. “Eh, not a big deal. I’ll just restart.”…

After restarting, I get to a black screen with this error message:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Cpu: 5 PID: 1 Comm: swapper/0 Not tainted 5.2.0-2parrot1-amd64 #1 Parrot 5.2.7-2parrot1

“Well…shit.” I can still load Parrot if I choose a different version in the Advaned options in GRUB. 4.19.37 still works. After booting into that version, I tried running:

sudo update-initramfs -u -k 5.2.0-2parrot1-amd64

That didn’t fix it either. I still get the same error upon booting. Luckily I can still boot into the older version…but at this point I’m at a loss. I’m not great at troubleshooting linux on my own. Any help would be appreciated!


Dell Inspiron 17 5000 Series
Intel i7-8550U
32GB ram
AMD Radeon R7 Mobile Series

i would make the following:

sudo apt autoremove -y && sudo apt autoclean -y

can you show us your source.list?

cat /etc/apt/sources.list.d/parrot.list

I suppose something could go wrong with your grub, can you boot and run sudo update-grub2?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.