Mount and detect CD-ROM error

I wanna replace my old linux distro with parrot home 4.0.1 amd64 but when i run the debian standard installer it doesn’t detect my usb. Help me pls…

Hi @Goldy_Fazbender do you boot in UEFI mode?

please use parrot 4.1 or the latest beta of parrot 4.2

generally speaking, ALWAYS make sure to use the LATEST parrot release available and never use old versions.


I want to use parrot 4.1 home. I forgot the version when i wrote this topic. I’m sorry

lol don’t worry

if you get CD-ROM detection errors, also take a look at our F.A.Q.


Thanks but i looked at the error again and it seems that the usb got corrupted somehow

I need some help. Do you know the MD5 hash for parrot home 4.1?

check the download page

1 Like

Hello @palinuro sorry to disturb you but I’ve tried everything but everytime I run it using the USB and I’ve tried over 16 times it wouldn’t let me proceed beyond the CD-ROM

Start a new topic and describe your issue in as much detail as possible, including what steps you took to get there.

please read our documentation

and start a new topic if you still encounter any issues

Just had this exact problem. Use Rufus to create the bootable usb, use the DD format not the ISO writing format. Then test it live and finally attempt the install.

how can i do that ? i tried to find the DD option but i cant

Use etcher! it’s way faster prettier and it just plain works. Etcher