mouspad not working Lenovo V330-14ARR


(Melvin Klovis) #1

sudo dmidecode |grep Version
Version: 3ECN27WW(V2.01)
Version: Lenovo V330-14ARR
Version: SDK0J40697 WIN
Version: Lenovo V330-14ARR
Version: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx

Mousepad is not working.

Sounds similar to this issue: https://unix.stackexchange.com/questions/427566/touchpad-on-lenovo-v330-thinkpad-v-series-is-not-recognized

sudo dmesg | grep -i elan
[ 5.234467] i2c_hid i2c-ELAN0616:00: i2c-ELAN0616:00 supply vdd not found, using dummy regulator

lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 06cb:0081 Synaptics, Inc.
Bus 003 Device 003: ID 0cf3:e500 Atheros Communications, Inc.
Bus 003 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04f2:0939 Chicony Electronics Co., Ltd
Bus 001 Device 002: ID 04f2:b604 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


What version of Parrot are you running? (include version, edition, and architecture)

OS: Parrot GNU/Linux 4.4 x86_64
+MMsohNMMMMMMMMMMMMMm/ Host: 81B1 Lenovo V330-14ARR
.My .+dMMMMMMMMMMMMMh. Kernel: 4.18.0-parrot20-amd64

  •   :NMMMMMMMMMMMMNo                Uptime: 15 mins 
       `yMMMMMMMMMMMMMm:              Packages: 2286 (dpkg) 
         /NMMMMMMMMMMMMMy`            Shell: bash 4.4.23 
          .hMMMMMMMMMMMMMN+           Resolution: 1920x1080 
              ``-NMMMMMMMMMd-         DE: MATE 
                 /MMMMMMMMMMMs`       WM: Metacity (Marco) 
                  mMMMMMMMsyNMN/      WM Theme: ARK-Dark 
                  +MMMMMMMo  :sNh.    Theme: ARK-Dark [GTK2/3] 
                  `NMMMMMMm     -o/   Icons: maia [GTK2/3] 
                   oMMMMMMM.          Terminal: mate-terminal 
                   `NMMMMMM+          Terminal Font: Monospace 13 
                    +MMd/NMh          CPU: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (8) @ 2.000GHz 
                     mMm -mN`         GPU: AMD ATI Radeon Vega Series 
                     /MM  `h:         Memory: 3857MiB / 6935MiB 
    

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

USB Boot

Configured to multiboot with other systems? (yes / no)

No

If there are any similar issues or solutions, link to them below:

https://ubuntuforums.org/showthread.php?t=2394494

If there are any error messages or relevant logs, post them below:


(Melvin Klovis) #2

dmidecode 3.2

Getting SMBIOS data from sysfs.
SMBIOS 3.1.1 present.
Table at 0x8C4E9000.

Handle 0x0000, DMI type 0, 26 bytes
BIOS Information
Vendor: LENOVO
Version: 3ECN27WW(V2.01)
Release Date: 06/19/2018
Address: 0xE0000
Runtime Size: 128 kB
ROM Size: 8192 kB
Characteristics:
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
BIOS ROM is socketed
EDD is supported
Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
5.25"/360 kB floppy services are supported (int 13h)
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
8042 keyboard services are supported (int 9h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
Targeted content distribution is supported
UEFI is supported
BIOS Revision: 1.27
Firmware Revision: 1.27

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: LENOVO
Product Name: 81B1
Version: Lenovo V330-14ARR


#3

Nice logs and docs :slight_smile: Have you tried this?


Also have you tried any of the settings from #49 on down?
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1795292

Also, have you updated all firmware?


(Melvin Klovis) #4

Thanks for your quick reply!

I tried to place ivrs_ioapic[32]=00:14.0 in grub boot (cmd)? and updated grub but that does not appear to work although the system boots alright. Do I have the right file?

/etc/default/grub.d and parrot.cfg

so that it looks like this:

GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Parrot
GRUB_CMDLINE_LINUX=“quiet splash noautomount ivrs_ioapic[32]=00:14.0”
#GRUB_GFXMODE=640x480

I tried to install a newer kernel but was unable to negotiate the step by step procedure, it seemed that there were parrotos specific methods to achieve the same that was keeping me from executing that method, but might be worth another try.

I would like to update the bios however I blasted the windows 10 partition thinking I was going off a Cliff like Thelma and Louis except me and Linux. So far that early decision has been my only regret. I figured it may also be possible to install the file in question just using a windows 10 container (if there is one available for Vagrant?).


(Melvin Klovis) #5

uname -a
Linux parrot 4.18.0-parrot20-amd64 #1 SMP Debian 4.18.20-2parrot20 (2018-12-10) x86_64 GNU/Linux

SO do I get an updated kernel for this OS from here? https://dev.parrotsec.org/users/sign_in


(Nico Paul) #6

no, use the

parrot-upgrade

command to receive the updated kernel


(Melvin Klovis) #7

Thanks for the clarification. I can confirm that command does indeed effortlessly upgrade the kernel to 4.19.

I can also state, sadly, that upgrading the kernel, rebooting, etc. does not get the touchpad working. But we are making progress and I am grateful for all the help.


(Melvin Klovis) #8

I have not updated the firmware b/c doing so is non-trivial sans a windows boot (I am regretting blasting win10 off the latop yes).

According to this https://superuser.com/questions/1052023/ioapic0-not-in-ivrs-table#1255206

There may be a linux workaround.

dmesg |grep ‘DEV_SPECIAL(IOAPIC|not in IVRS table’

[ 0.164325] AMD-Vi: IOAPIC[4] not in IVRS table
[ 0.164328] AMD-Vi: IOAPIC[5] not in IVRS table

Going to try the fix via that link and will report back.