My Metasploit-Framework is two versions behind

Briefly describe your issue below:

Not sure this is the right location for this but I noticed when playing with a box on a ctf site I didn’t have the updated framework. I did some digging and found the github link below and it seems the last push was 21 days ago but mine is still "metasploit v5.0.53-dev "

I’ve tried a few things outside of removing and installing my own version of it.
Is this something that will just get pushed out in time or is there something I can do to get the latest version?

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Linux parrot 5.3.0-1parrot1-amd64 #1 SMP Parrot 5.3.7-1parrot1 (2019-11-04) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)


Configured to multiboot with other systems? (yes / no)


If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Hello. Are you sure to have all the packages up-to-date? Which version of Parrot are you running?

Hey Tissy thank you for the reply.

Yes apt update is current doesn’t show any new packages.
I’m using Parry-Security installed from the 4.7 x64 iso.

I tried using a different official mirror but oviously that didn’t change anything :stuck_out_tongue:

**** APT readout **** (remove 888 can only post two links being new)
Hit:1 stable InRelease
Hit:2 https888:// rolling InRelease
Hit:3 https888:// rolling-security InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.

*** msfconsole --version ***
$msfconsole --version
Framework Version: 5.0.53-dev

** Apt Search metasploit-framework **
$apt search metasploit-framework
Sorting… Done
Full Text Search… Done
metasploit-framework/rolling,now 5.0.53-parrot1 amd64 [installed]

Update to this… I added up rolling-testing source just to see if it would pull…
A lot of updates are available but metasploit-framework wasn’t one of them.

I’m guessing we just havn’t had a push on the update or no one is testing from the newest versions?

Okay, our devs are working on the new metasploit version.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.