My OS show black screen whenever i log in?

Hello everyone!

I am using parrot Os (latest version), i’ve had installed it last month, it was workin fine at that time, didnt really use it after that because i was workin on my other laptop. But now that i’ve tried using the laptop in which linux is installed, it shows me black screen after i log in.

I dont know what is the issue, is it the hardware or the software,

hard to say from that but could be a problem with broken update or possible graphics card issue.

Can you get into terminal? If you need to jump to terminal login to work in command line hit ctrl+alt+f1or ctrl+alt+f2. Then su root and see if you get any errors from:

parrot-upgrade

We might also get some clues by the output/result of

startx

Reply with any errors

1 Like

Thanks for your reply, actually after using command line root and doing startx, the os started and the black screen did not appear but the upgrade shows (temporary failed resolving ‘deb.parrot.sh)’ after that it just failed) i thought it might be cause internet was not connected, so i started network manager, network manager is not connecting either.

Try: cat /etc/resolv.conf
I had it a few times that my file was empty. This leads to failing resolv! If its empty than you could use the dns that parrot provides sudo anonsurf dns

Thank you for your reply, i do have a dns server that it shows, network manager has also started working now but i cant get the device to upgrade, it is showing the same error. Failed to fetch https://deb.parrot.sh/parrot/dists/rolling/InRelease

Odd. I just now successfully updated/connected fine. Your system is now confirmed connected to internet successfully now? Can you check if another website resolves? If you get another website to resolve/load successfully give parrot-upgrade a try again.

I remember a time when parrot.sh did not load for me for a couple hours. Maybe it will work for you now. First ensure another website loads so we know everything is working.

I dont know what is wrong with the os, i think the graphics card is not enough for it since it takes almost 15 mintes for it to show the screen after i enter the password to my account, it did work earlier, but now that iv restart it, it has the same problem of black screen :frowning: should i upload the video? I dont know what is wrong with it.

It says server not found in the browser, even though the internet is working fine on my other laptop and mobile

okay you have confirmed internet is working fine on OTHER machines but can you confirm your internet is up fully connected on THIS machine? If you aren’t connected to the internet on Parrot machine it is important to let us know so we know what direction to go on.

There are too many possibilities given the very little information you have given us so far.

DNS not resolving could be dns problem or internet connection/wifi altogether problem. Let’s test your connection to the internet & ability to send/receive packets.

What happens when you ping this google server? :

ping 172.217.29.14

Also please paste output of:

iwconfig

try sudo anonsurf dns


Heres the output
Hope you get something from it, also the internet is not working in the machine, it says secure connection failed in firefox,

During upgrade it shows: could not handshake:Error in the certificate verification. [Ip: 198.251.90.161.443]

Try ping parrotlinux.org
If its dont work then send the ouput of cat /etc/resolv.conf

1 Like

Looks like DNS problem. It would give you that error msg for certs. Follow what evpne d43m0nhLInt3r said & paste /etc/resolve.conf for us.


Here you go!

It seems to work. You are able to ping parrotlinux.org and the conf file looks good. Its also better to remove metadata when you want to upload an image: https://f-droid.org/en/packages/com.jarsilio.android.scrambledeggsif/

So why am i not able to connect to internet? Do you know how to fix it?

does this still persits? If you can ping 172.217.29.14 and also parrotlinux.org than you should be connected.

I would try to update the system again: sudo parrot-upgrade
and open 172.217.29.14 in Firefox
If it dont work then try connect to the Tor Network:
Option 1: Start Tor Browser
Option 2: sudo anonsurf start

Tor is also not working it stops and shows this. It pings the ips perfectly, but internet does not work whether im installing something or updating

how about reinstall because I dont know what the issue could be