Mysql pentesting

Hello,
i am tryed to pentest my Mysql Server. At the moment i was playing around with this Tools: Hydra, Medusa and Metasploit. The Problem is that all this tools wont work with a mordern mysql Server (Version 8.0.21).

Metasploit error:
[-] 192.168.178.20:3306 - 192.168.178.20:3306 - LOGIN FAILED: root:123 (Unable to Connect: unknown charset number: 255)

Hydra wont work with proxychains. So the IP will be blocked after x attempts.

Medua only supports Version 5.x of mysql server.

I wonder if ParrotOS got a new tool that can handle mysql server 8.X and work the right way with proxychains (every attempt with a new ProxyIP)?