Necesito actualizar Grub?


#1

Por lo general cada vez que actualizo mi systema es un éxito. Sin embargo, he instalado desde zero esta vez y al iniciar mi portatil se muestra grub, al aceptar la primera opción luego muestra un guión bajo que palpita y luego me quedo con una pantalla sin el guión palpitante. Se escucha que esta funcionando el disco duro, mas no hay señal de la pntalla del login. Es así que tengo que apagar el systema e iniciar de nuevo; preo esta vez en “recovery mode” , lo cual sirve. Alguien me podría señalar a que se deba esto? Y si necesito actualizar grub? Que dudo por haber sido la mas reciente imagen montada a un usb con balera etcher.


(David) #2

Es posible que el instalador de Grub tenga un problema, por lo que describes (Grub Rescue). Prueba con

sudo update-grub

A ver qué tal :slight_smile:
El boot order puede influir en esto también si tenemos dos SO en diferentes HDD’s.


#3

Actualizar grub no parece ser la solución. Cuando recién se instala parrot en un ordenador, claramente se mira que grub esta siendo instalado y actualizado. Lo que pasa es que al iniciar mi poratátil, tengo que seleccionar 4.18.0-parrot10-amd64 para que inicie. Esto lo he verificado en dos distintos portátiles. Justo después de la instalación hago un apt-get update seguido de un dist-upgrade. Es cuando enciendo mi laptop que pasa esto. Es decir, la instalación es un exito. Pero cuando actualizo e inicio tengo que merondear con grub. Porfavor ayuda.


(David) #4

No tengo ni idea de qué puede ser con la información que tengo ahora. Alguna incompatibilidad de drivers? Lo que describes a mí me pasó una vez instalando mal los drivers nvidia… Más info. Specs. Lo instalaste con Echter?


#5

Es posible, como dices, que el problema tenga algo que ver con los drivers. Aunque se supone que estos vengan actualizados con el nuevo kernel. Aquí muestra alguna información antes de haber actualizado.

Como he dicho, despues de hacer un reboot solo puedo acceder parrot eligiendo 4.18.0-parrot10-amd64 en grub. Aquí la información una vez actualizado.


#6

Si decido editar el codigo de grub para poder así acceder 4.18.0-parrot20-amd64, esto es lo que pasa durante el login usando nomodeset. (mediante tty)


No puedo acceder mediante tty asi que regreso al gui (Ctrl+Alt+F7) y una vez dentro aqui hay alguna información.

Que puede estar mal con los drivers de Intel? O es que deba esperar a 4.19


#7


(David) #8

Pues de intel graphics no tengo yo ni idea :frowning: … es una de estas integradas en un portátil no? En portátiles no he tenido ningún problema con parrot hasta la fecha, la verdad… y en desktop uso drivers nVidia, que una vez lo hice mal… la primera jajaja y luego ya.
A ver cómo lo vas sondeando.
He hecho una búsqueda rápida y he visto potencial en “intel graphics 540 linux”. Prueba!


#9

El problemilla al iniciar Parrot OS se a resuelto con la nueva versión 4.5

┌─[lenteja@parrot]─[~]
└──╼ $uname -a
Linux parrot 4.19.0-parrot1-13t-amd64 #1 SMP Debian 4.19.13-1parrot1.13t (2019-01-09) x86_64 GNU/Linux

Sin embargo no esta utilizando el “más reciente” kernel 4.20, lo cual no me molesta en lo absoluto. :wink:


(Jesús Garcia ) #10

asi como el cuento de la gallina de los huevos de oro, si te está funcionando bien, no es necesario actualizar.

Pero si te preocupa estar desactualizada usa el comando
“sudo apt-get upgrade” y se actualiza todo tu sistema