Need a veterans help please weird issue

Briefly describe your issue below:
well everything was completely fine been using parrotsec for a couple months now (ill never go back to windows) but 3 days ago i tried using YOUTUBE-DL and ever since im having issues ive completely removed it in terminal and in apt ive tried reinstalling its always there no matter what i cant open dolphin even if i try via terminal i tried reinstalling and problem persists i try killing yt-dl but it says it not even installed

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
└──╼ $dolphin
Usage: dolphin [OPTIONS] URL [URL…]
dolphin: error: You must provide at least one URL.
Type youtube-dl --help to see a list of all options


sudo apt purge dolphin youtube-dl

and reinstall it.

Ok I followed what you said I’m grasping at straws here I don’t know what else to try Purge and reinstall and still getting the same message

It’s really odd I removed both and only reinstalled dolphin and rebooted and tried sudo dolphin and it still responds as YouTube-dl … It’s like the os thinks dolphin is YouTube-dl now how do I fix this

How do you have installed youtube-dl?
from GITHUB?

First yes I followed the instructions on GitHub , I also tried from synaptic after removal

and what do you want with dolphin?
maybe i am wrong but dolphin is a shi… browser for android and ios right?

Dolphin is my native file manager that came with parrotsec kde , and no this is a laptop not an Android I can’t do anything that involves my file manager no matter how I try to run it really messing my weekend up

Ups, sorry mate! :slight_smile:
I have never used kde in my life i think …

Look with

which dolphin

show me the output please

└──╼ $which dolphin

and when you open it with


the same thing happens?

└──╼ $/usr/local/bin/dolphin
Usage: dolphin [OPTIONS] URL [URL…]

dolphin: error: You must provide at least one URL.
Type youtube-dl --help to see a list of all options.

ahhhh man these situations are honestly like blessings in disguise because they make you learn the hard way so upon opening /usr/local/bin/dolphin with nano i found that python somehow made a bogus directory in dolphin for youtube-dl’ .py script so i just got rid of it with sudo rm /usr/local/bin/dolphin thanks for the help my friend problem solved

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

Nice one!
these are the best steps to learn something about your system … with trail&error.

but for the future:

  • make backups or snapshots
  • do not install software over multible ways
  • find out how to install. and deinstall. the tool the debian/parrot way before you install. it :wink: