Network Controller Issues

Briefly describe your issue below:
Hello. I have a 2019 HP Envy x360 running Win 10 Home and dual booted with Parrot, Kali, and Arch. Not a single one will recognize my network card! It constantly switches between “device not ready” and “device no managed”. It is an Intel Cannon-Lake 9560 AC chip. I have no issues on Windows. Ive tried intsalling new drivers to the /lib/firmware directory with no resolve. The only way i have internet access is to use a 15 y/o 802.11g usb adapter. Kernal is 5.2.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot OS Home (current as of Oct 7th 2019)
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard
Configured to multiboot with other systems? (yes / no)
List your networking hardware (make, model, firmware version):
Intel Cannon-Lake 9560 AC
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

I don’t think there is currently any linux support for that device…

You can either downgrade to Kernel 4.19 which uses the working iwlwifi driver v38 or you

cd /lib/firmware
sudo cp iwlwifi-9000-pu-b0-jf-b0-41.ucode iwlwifi-9000-pu-b0-jf-b0-46.ucode

and override the faulty driver with the last one that worked. If you are unsure about that you could of course rename
sudo mv iwlwifi-9000-pu-b0-jf-b0-46.ucode iwlwifi-9000-pu-b0-jf-b0-46.ucode.kaputt the module first and then copy the working driver by using the above cp command.
Your decision.

Alright. I’ll try both just to see which works first. i might ask for some help. Still new to this stuff :sweat_smile:

nevermind that seems pretty easy ill try it tonight

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.