Network driver installation

Briefly describe your issue below:
I can’t seam to get the driver installed I don’t know how to download it from Firefox and I don’t know how to run it from the install disks.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)standard

Configured to multiboot with other systems? (yes / no) yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

which device do u have?

lspci | grep Network
lshw -class network

Hey im not sure im like a deer in headlights here brand spanking new and dont really know what im doing. ill be as painless as i can. i have a dell latitudee6420 idual booted parrot os in my system i been faced with a few issues 1 i cant boot my windows 7 anymore i dont see that option in my grub boot menu 2 from time to time i loose my network manager and it acts as if there was never one i figured that up but i have tried to install a network adapter a tp-link n150 i belive but i cant get it read in my cd or usb
any and all help will be apprciated

wow, ok, sorry but you are hard to understand for me :slight_smile:

you should have run one of those commands in your linux terminal to see what network device u got:

lspci | grep Network
lshw -class network

from the specifications of your laptop you should have an intel wlan device buildt in.
this is the driver for Intel® Centrino® Ultimate-N 6300 :

Unzip and Copy the files into the firmware directory, /lib/firmware and reboot

for the booting problem you can try to run sudo update-grub and reboot. if that doesnt work, you might have done something wrong during installation/partitioning. try reinstalling parrot. if it still doesnt work, you can read here and try to fix it:

if that also doesnt work use the windows troubleshooter option to fix you MBR and if you killed your windows installation, u gotta reinstall windows.

1 Like

Thanks so much dude. And I’ll be a bit more informative. I did the dual boot when I installed parrot os. prior to that I had installed parrot os on a usb device. I still have that device now I feel that it’s best I start over. Under devices I see the windows partition but not the actual windows. I feel I deleted it unknowingly. What would be my best option.?

sounds like you messed up your efi boot partition. the last link i posted in my previous post contains instructions to fix your grub…

Hi. So if your grub doesn’t show windows you may try running sudo os-prober .

Though even if os-prober doesn’t find your windows, it means that there’s no boot file for it and you have to recover it manually. You can do that by mounting your C:/ partition and grabbing boot file from it, then mounting EFI partition and copy that file there. Though it sounds crazy, it’s not that hard.

All these commands have to be done in live mode.

  1. You have to find out where’s your Windows C:/ partition. Run sudo lsblk and guess it by size, or run GParted and find out what is the number of partition (i. e. /dev/sda3 or /dev/nvmen1p1 ).
  2. After you find out partition number, you have to mount it in order to grab the file. Let’s assume that your partition is /dev/sda4 . That’s what you need to do:

sudo mount /dev/sda4 /mnt - this will mount your C:/ windows partition in read-only mode;
cp -r /mnt/Windows/Boot/EFI ~/EFI-BACKUP - this will copy a copy of microsoft boot folder in your home ( ~ ) folder;
sudo umount /mnt - unmount windows partition;

  1. Now when you have efi backup folder you have to mount EFI partition and copy it there. Run sudo lsblk again and find your EFI partition (usually it’s in top and around 100-500 MB)

Let’s say your EFI partition is /dev/sda2/ :

sudo mount /dev/sda2 /mnt - mounts your EFI partition;
cp -r ~/EFI-BACKUP /mnt/EFI/Microsoft/Boot - copies windows boot files to EFI;
sudo umount /mnt - unmounts your EFI partition.

  1. Now you may run sudo os-prober again, and if it finds a windows boot manager run sudo update-grub2 .

if you dont want to mess around like this then you can fix your MBR within windows troubleshooter:

Fix the MBR in Windows 7

You need your original Windows 7 installation DVD to boot into System Recovery Options and run Command Prompt.

If you don’t have the Windows 7 installation CD/DVD to run Command Prompt, go to Fix MBR with Easy Recovery Essentials.

The instructions are:

  1. Boot from the Windows 7 installation DVD
  2. At the “Press any key to boot from CD or DVD…”, press any key to boot from the DVD
  3. Select a language
  4. Select a keyboard layout
  5. Click Next
  6. Select the operating system and click Next. The “Use recovery tools that can help fix problems starting Windows” must be checked when you select the operating system.
  7. At the System Recovery Options screen, click on Command Prompt

Windows 7 System Recovery Options Screen

  1. When Command Prompt successfully loads, type this command:

bootrec /rebuildbcd

  1. Press Enter
  2. Type the next command:

bootrec /fixmbr

  1. Press Enter
  2. Type the next command:

bootrec /fixboot

  1. Press Enter
  2. Remove the installation DVD from the disk tray and restart your computer

but this will overwrite grub. you then have to use the usb/cd installer of parrot and install it again, if you dont wanna mess with grub.

so either you mess with grub or you mess with mbr. the easiest way is to fix your mbr in windows troubleshooter and reinstall parrot, once u have your windows booting up again. this way you dont have to touch grub.

Hello I have tried all of those but I don’t know what I’m doing when I tried sudo update-grub and I only see the parrot boots I can see there’s a partition with the words crypt next to it I would assume that’s where all the regular stock windows program are I don’t know how to decrypt it

in your previous post you say that you can see your windows partition. so where can u see it and how do you know its windows? what filesystem does it have? and crypt means its an encrypted partition. did you use any windows encryption tool or did you install the parrotos on a encrypted partition?

why dont you try to use your windows installation medium and follow the steps in the troubleshooter to fix your MBR, then you know for sure if you killed your windows or not. in case its dead i suggest you format and repartionate everything and start from beginning.

wheni i go the devices on my desktop toolbar i see three options boot, parrot system, and 297.5 gib encrypted drive when i go to it it says drive not assessible i dont have the actual windows disk for mr to install it if i lost it i say thats where the windows is beacuse i remember how much gb i had for the laptop.i dont think i useed any incyprtion tool i just followed a youtube vidoe step y step
i also dont know hoe to download anything from parrot as i am very new to computers in general

It says I’m not authorized to open the drive if I’m the only user for the pc

well the question is did this video tell you to encrypt your windows installation or not. if its not an linux/parrot encrypted disk, its normal that you dont have access as it waits for windows to ask for decryption. so lets assume you have windows on that partition and its encrypted. then download the windows 7 installation iso from here:

u need your windows key to download it. if you dont have your windows 7 key, then u need to find the iso for yourself, as i think im not allowed to tell you how to download it without a key. not sure how legal that is. but no matter what, you need the windows 7 iso and burn the image to an usb stick and then follow the steps to fix your mbr.

and if you are new to linux or computer in general im not so sure if parrot os is the right starting point for you. there are much easier and better documented beginner linux distributions on the net like Linux Mint. (sorry for the advert but i want to help him to get an easier start)

hello Daniel
so i am having a hardtime getting anything downloaded on parrot any program other then the stock program it goes to this sirikali box on the screen asking for a key i dont know what this key is and it doest take any of my regular passwords do you think you can help. I also dont get access to my usb drives it does the siri kali thing. Look i just want to get windows back on and the delete this and get a more noobie site like you said

sirikali seems to be an encryption tool that i personally dont have any experience with. if you dont care about your old windows installation just format from inside parrot with partman. when u formated a drive, the encryption is gone too and you dont need the key to format. then u can install windows again from your windows installation disk. i posted above how you can get it, if you dont have it anymore. if you need your files on the encrypted windows, then i also posted above how the access the windows recovery area.

but if you lost the key for your encryption, i guess your best option is to format everything and start from beginning. sorry i cant help you more as understanding you what exactly happens gives me a hard time. sorry but i wish u good luck!

Thank you Daniel. After multiple tries I could not get it back to windows like I wanted to I could not download nor unlock my usb to install windows. I am downloading windows into a usb from a different computer to install it into the the new system it’s just not a 7 like it was originally but I’m hoping it works. I appreciate all your help and tips.

Keep in mind that Windows will remove your EFI partition if it decides to sit there or will create a new one for itself. What problems did you face when you tried this? Did you run sudo os-prober?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.