Network not working without anonsurf

I used anonsurf for a while and today i recognize that without anonsurf my internet stop working
I tried to stop anonsurf, disable it on boot, restart networking service etc. but still i don’t have internet connection

When i start anonsurf internet work properly
On second pc with older version of parrot everything works fine

My system is up to date

OS: Parrot OS 4.11 x86_64
Kernel: 5.10.0-6parrot1-amd64
Anonsurf Version: 3.1.8+parrot0

Likely there is a trouble with your DNS setting. There is a known uncommon bug that when AnonSurf stops, it restores DHCP’s DNS and client’s machine can’t connect internet. About this problem, only very few users have this issue and some users can’t reprocedure after change DNS.
Please send me screenshot of cat /etc/resolv.conf. And after capturing the screenshot, you can try sudo dnstool address <your favourite DNS> to change DNS. IF this doesn’t work, please let me know in here.

I used dnstool address and this command change nameserver but internet still don’t work properly without anonsurf

You have to run sudo dnstool address 1.1.1.1 or anything like that


I tried with a few DNS provieders [Cloudflare, Google, OpenDNS],
restarted PC, anonsurf, network services but still have the same issue

Did you check Iptables rules?

Thanks for your help but i will reinstall my whole operating system
Its sometimes a fastest way of problem solving

Bro how can you resolve this problem…i have the same issue.i did all the things same as like you.but it didn’t work