No audio on headphone or External speakers

Briefly describe your issue below:
uname -a
Linux parrot 5.6.0-2parrot1-amd64 #1 SMP Debian 5.6.14-2parrot1 (2020-05-23) x86_64 GNU/Linux.

I installed Parrot Security MATE 4.9.1 dual booted with windows 10. Internal speaker i,e without connecting headphones or external speakers it’s working, but with headphones or external speakers I don’t hear anything.

On windows 10 its working good.

I tried this

I_Have_Treasure as suggested

Additional Kernel Boot Parameter
first go to /etc/default/grub then add snd_hda_intel.dmic_detect=0 to GRUB_CMDLINE_LINUX_DEFAULT= after quiet splash then save it and run sudo update-grub then reboot the system and check if it is working or not ,if it works keep it else you can remove this.

But didn’t work.

I ran alsamixer from the terminal in alsamixer F6 to select device and maybe adjust volume and PCM settings.

Even here all the settings are up and running

lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

One solution suggested by Prasandeep:
Firstly, Reload Alsa
$ sudo alsa force-reload

Reinstall Alsa and PulseAudio

$ sudo apt remove --purge alsa-base pulseaudio
$ sudo apt install alsa-base pulseaudio

Reload ALSA again and reboot your computer.

sudo alsa force-reload
sudo: alsa: command not found

Didn’t work too.

As suggested

Fix No Sound (Dummy Output) Issue In Ubuntu With SND HDA Intel

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

alsa-base.conf this file doesn’t exist in first place and If I run the above command it will create this file with only options snd-hda-intel model=generic.

Didn’t work.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot Security MATE 4.9.1

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK

Configured to multiboot with other systems? (yes / no)
Yes

List your hardware specs to include make, model and firmware (when applicable):

If there are any similar issues or solutions, link to them below:



If there are any error messages or relevant logs, post them below:
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Please help me here.
Thanks in advance.