no device for installation media was detected

Hello folks

I’ve been trying to install Parrot OS on VMware for 1 week now and I get the same error message every time, namely “no device for installation media was detected”. I can install Kali Linux without any problems. I’ve already tried VirtualBox with the same result.
Note: I am a beginner and a noob when it comes to operating systems other than Windows.

Experiencing the same issue with the 4.11 home iso, trying to install within virtualbox:

Name: Parrot-home-4.11_amd64.iso
Size: 2094116864 bytes (1997 MiB)
SHA256: 6C22655D781A118ACA88090B12DF2D7B1A86AC3134B5F806D4F06D5AA23BDBC3

Only reference to the underling problem I could find is here:

" miss a isofs.ko driver in /install/initrd.gz and it exist in /live/initrd.img so that’s why it’s ok with LiveCD boot option but failed with Install option"

Same issue with security ISO.

Parrot-security-4.11_amd64.iso
SHA1: 4156aafd42ba06933808e83a6938cee75079806f
SHA256: 7547f42857ec20f4f7adb3ad88bda8c9d0d3c85411a1f0333af89903fab2a6d1

1 Like

Am having similarly issues with Parrot-security-4.11_amd64.iso

Just downloaded the iso about 3 days ago

for a better installation ensure, on Parrot in ISO file you need if you are in Windows to switch to dual boot mode, the Win32DiskImager program which locks the USB key for a better installation. Here is the download link: Win32 Disk Imager download | SourceForge.net