No dGPU Output

*-- Hi all, hope you are well. Before I start I would just like to say I am completely new to linux and thusly may not fully understand some of the answers provided, however I could really use some help on this one as I’m loosing the will to live

So, I currently have an issue where I cannot for the life of me get my ParrotOS install to display over the HDMI port to an external monitor. At this point I don’t really care about Hashcat or any fancy things. I only need to get the external monitor working for my studies.

I have followed the blacklisting guides etc for Nouveau, however when running anything it simply shows that the card has no driver attached, however when re-running the Nvidia install it states it’s on the latest version. No other monitors are detected through xrandr, but if I plug the cable in I get a pop up message on the OS saying “no display selected” (or Something similar)

Honestly, I am probably missing something really simple, but as I’m not used to Linux I would know.

Any help on this would be really appreciated.

System Details:
Razer Blade Stealth 2080 Super (Intel iGpu + dPGU)
Parrot installed on: Live USB with Luks Encrypted Persistence (Sabrent USB-C Dock + 512GB NMVE drive

Things I have tried:
Rebuild multiple times using Etcher and various other methods, so not a image building issue.
Followed official Parrot documentation for installing with iGPU and dGPU to no avail
Followed countless forum posts
Probably lots of other stuff I can’t remember)
, --*


  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):
    VERSION_ID=“5.0”
    VERSION=“5.0 (LTS)”
    VERSION_CODENAME=bullseye

  • Kernel version (if you are not aware of it, open terminal and type uname -r):
    Host: parrot Kernel: 5.14.0-9parrot1-amd64 x86_64 bits: 64 Desktop: MATE 1.24.1 Distro: Parrot OS 5.0 (LTS)

  • Logs/Terminal output (use pastebin or similar services):
    sudo lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630]
    01:00.0 VGA compatible controller: NVIDIA Corporation TU104M [GeForce RTX 2080 Mobile] (rev a1)

$sudo nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU104M [GeForce RTX 2080 Mobile] [10de:1e90] (rev a1)

Checking card: NVIDIA Corporation TU104M [GeForce RTX 2080 Mobile] (rev a1)
Uh oh. Failed to identify your Debian suite.

System: Host: parrot Kernel: 5.14.0-9parrot1-amd64 x86_64 bits: 64 Desktop: MATE 1.24.1 Distro: Parrot OS 5.0 (LTS)
Machine: Type: Laptop System: Razer product: Blade v: 3.04 serial: BY1944A77703461
Mobo: Razer model: CH530 serial: N/A UEFI: Razer v: 1.05 date: 09/19/2019
Battery: ID-1: BAT0 charge: 77.7 Wh (98.5%) condition: 78.9/80.2 Wh (98.4%)
CPU: Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP cache: L2: 12 MiB
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
9: 800 10: 800 11: 800 12: 800
Graphics: Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
Device-2: NVIDIA TU104M [GeForce RTX 2080 Mobile] driver: N/A
Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
Display: server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.5

$sudo apt install nvidia-driver
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
nvidia-driver is already the newest version (470.57.02-3).
The following packages were automatically installed and are no longer required:
libct4 libmotif-common libxm4 python3-aiofiles python3-fastapi python3-orjson python3-pydantic python3-slowapi python3-starlette
python3-uvicorn sqsh
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

NVIDIA-BUG-REPORT
Jan 20 16:42:34 parrot nvidia-persistenced[1271]: Started (1271)
Jan 20 16:42:36 parrot kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 239
Jan 20 16:43:23 parrot kernel: NVRM: The NVIDIA GPU 0000:01:00.0
NVRM: (PCI ID: 10de:1e90) installed in this system has
NVRM: fallen off the bus and is not responding to commands.
Jan 20 16:43:23 parrot kernel: NVRM: The NVIDIA probe routine failed for 1 device(s).
Jan 20 16:43:23 parrot kernel: NVRM: None of the NVIDIA devices were initialized.
Jan 20 16:43:23 parrot kernel: nvidia-nvlink: Unregistered the Nvlink Core, major device number 239
Jan 20 16:43:23 parrot nvidia-persistenced[1271]: Failed to query NVIDIA devices. Please ensure that the NVIDIA device files (/dev/nvidia*) exist, and that user 137 has read and write permissions for those files.
Jan 20 16:43:23 parrot nvidia-persistenced[1271]: Shutdown (1271)
Jan 20 16:43:23 parrot nvidia-persistenced[1209]: nvidia-persistenced failed to initialize. Check syslog for more details.
Jan 20 16:43:23 parrot systemd[1]: nvidia-persistenced.service: Control process exited, code=exited, status=1/FAILURE

  • Screenshots:

any help anyone?

Hello. First of all: have you installed the Nvidia drivers? Because it doesn’t look like it from what I’ve read. If you have them installed, by typing sudo nvidia-settings should bring up the GPU manager.

Hi Danterolle hope you are well.

I followed the documentation on this link https://docs.parrotlinux.org/nvidia-drivers.html#nvidia-driver-on-a-computer-with-igpu-and-dgpu

I have been through this several times, also tried via the Nvidia repository and also the Parrot Repository

Thanks

Hi all

Any thoughts on this please, it’s really causing me issues.

Thanks

Hello. Very sorry for the so long reply. When you run hashcat, you should run command like that __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia hashcat. Make sure you installed nvidia-driver
For external monitor: I’m having same issue with my gigabyte g5 KC laptop. Everything I understand is: HDMI port connects to Nvidia card, and it just doesn’t work (big thanks to hybrid graphic tech LuL).

No problem at all.

Yes just to recap, I’m not really bothered with other items like hascat etc at this moment, purely just the output to monitor.
The really annoying thing is, occasionally when GRUB appears, it displays over the HDMI connect to the discrete NVIDIA, then as soon as Parrot OS loads, it disconnects. (which is even more annoying than it not working at all) :slight_smile:

Even if I could get it to display over the USB docking station that would be enough :slight_smile:

Oh man!!! I mean i spend a week to try replace my driver with nvidia only. It breaks my GUI and everything and it just doesn’t work. The ONLY thing i can do is make nvidia-settings show HDMI in the list of output device. And ofc, HDMI never worked. For my laptop, I have an other port connects to Intel graphic. I didn’t try but I hope it work.
For Nvidia HDMI, i tried bumblebee method, digging everythign in ARch forum, Linux mint forum, … switch prime, … and all methods didn’t work at all.

Damn, well that sucks haha. If you can’t fix it I have no hope being a linux noob :rofl:

How’s about pushing display through a USB docking station?

I have managed to get my USB dock working
So no Nvidia, but i can at least study on more than a 15" screen now

Bizarrely, the USB display would not work until I closed my laptop lid. Now it works if it’s open or closed.
No matter I can can work now.

Thanks for the input

what the… LoL. I mean buggy laptop lid close is something Linux has, and this is more weird LuL.

Anyway I’m happy that it’s working for you :smiley: