No grub menu after setup

Briefly describe your issue below:
Hi all,
I’m trying to install Parrot OS alongside windows 8.1 on a HP Elitebook Folio 9470m
The laptop has

  • windows 8.1 already installed
  • 16gb of ram
  • Standard 750gb hd

In the “BIOS” I’ve set fast boot off, secure boot off
boot mode is set to uefi

I’m installing from a 8gb usb drive with Parrot-security-4.7_x64.iso
Parrot was loaded to usb drive with Win32DiskImager
I’ve had no trouble getting Parrot OS to work live from the usb drive

No errors are displayed during the partition and grub setup stages of the install.
I will note that when setting up partitions, a partition type of /boot is created, NOT /boot/efi

Once install is completed, I remove usb media as instructed, the system restarts and does not display any grub menu, boots into windows.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I’ve tried Debian Standard / Debian GTK NOTE : mouse does not work during installer

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
No error messages. System does not boot, so no logs either.


It may be in the way you built the USB. The Parrot documentation suggests using Etcher. I used Etcher and had no problems in my install. Maybe try using that instead of Win32DiskImager? I know it runs fine using the Live, but you just never know. I have had images work great on live but wouldn’t install, even as a VM.

Link for reference.

1 Like

I have an HP ProDesk and ran into a similar issue. I solved it by going into the BIOS. I had to uncheck the option for using Microsoft’s signed keys. If this is checked, then you won’t be able to boot into anything properly unless the OS is signed by Microsoft. I believe it is under the Boot settings or maybe the advanced settings when you push F10. I also had to make sure “fast boot” was off and that I checked all the Virtualization boxes. I configured a start delay to 5 seconds and made sure the boot order was correct. Once I did this, I was able to run Parrot with no problems. I also did not have a /boot/efi file that was recognized by my computer, however once I made these changes I was all set.

Also, if you go to HP’s drivers downloads page and enter that you use Windows OS, you will be able to see what updates your system needs. Mine for example, said there was a bug that prevents certain usb and media from being recognized to boot from. If that is the case, you can try to update your BIOS and firmware from HP.

Hope that helps!

Hi all,
So after trying a few random things I’ve decided to follow a new process from start to finish and will document what I’m doing and the results here.

Reference Guide :

  • I’ve used the built in Windows 8.1 tools to remove partitions created during previous linux os setup attempts. Boot windows > Run prompt > compmgmt.msc > Disk Management. Once that was done I rebooted the laptop to make sure everything was ok.

Updated my BIOS with legit file from HP, it was 6 years old.

Disabled Fast Startup within windows power options (This is different to the BIOS setting)

Used windows 8.1 Disk Management tools to create unallocated space for linux . Run prompt > compmgmt.msc > Disk Management. Shutdown. Start up… windows will make sure the changes are ok.

Reading through the guide linked at the start of this I noticed mention of UEFI CSM (Compatibility Support Module) (( The Compatibility Support Module (CSM) is a component of the UEFI firmware that provides legacy BIOS compatibility by emulating a BIOS environment, allowing legacy operating systems and some option ROMs that do not support UEFI to still be used)) So I wondered if that option in my bios could be prompting the linux installer to try and do something other than install grub in uefi ??? I changed my Boot Mode to : UEFI Native (Without CSM)
… AND discovered that the Parrot OS installer ( debian and gtk ) boot to a distorted view.
If I revert the Boot Mode to UEFI Hybrid (With CSM) the text/gtk installers work again.

I learnt the same thing when I made a backup of my HP Laptops EFI/boot/hp recovery partitions with clonezilla ( Clonezilla website states that you must use “amd64 Stable Alternative - Ubuntu based” for it to work with a UEFI system ) But using the recommended AND “amd64 Stable - Debian based” images in live mode both fail unless I boot in UEFI Hybrid mode.

Here’s a pic of the Parrot OS text installer when booting in Native UEFI mode.

Hi [KnightedParrot]
Regarding using specific software to create my boot media.
When I read your suggestion about Etcher, I was about to backup my original efi . boot . hp recovery partitions so had a crack at using Etcher to create a clonezilla live boot usb. The laptop did not recognize the usb drive during boot if created using Etcher. I did have some success using a program called Rufus to get the laptop to recognize clonezilla live usb. I’m going to load parrot os iso onto my 8gb drive using etcher and give that a go.

Hi [Kamakazee]
Thanks for the suggestion about Microsoft signed keys, I’ve got fast boot and secure boot disabled. But not sure what you mean by Virtualization ?


Ok first, let me just say how much i despise UEFI lol. I actually just want coreboot. I do not like how Microsoft has their BIOS/UEFI/EFI whatever other variations there are with them. If you have the EliteBook then you should have no issues running Parrot. The problem is with Microsoft and Windows.

By Virtualization, I mean there might be some settings for you to check a box named something along the lines of Virtualization Vtxd or Vtx or something. I don’t remember the exact name right now. But if you see something like this, make sure you check it.

Also I had to turn legacy off and secure boot off for it to bootup.

Can you take some pictures of your BIOS menu and the settings you have right now?

Hi Kamakazee,

“coreboot” looks interesting…

Pictures of BIOS > Boot Options & Device Configuration…

Exploration of my BIOS reveled the virtualization settings you mentioned.
BIOS root > System Configuration Tab > Device Configurations menu

  • Virtualization Technology (VTx)
  • Virtualization Technology for Directed I/O (VTd)
    Bother options were disabled, I’ve enabled them now.

My live usb has been re-created with Etcher
I’ve enabled both virtualization options.
At this stage starting the text or gui install leads to scrambled onscreen image if I’m in Native UEFI mode. Setting Boot mode to UEFI Hybrid allows me to start install process, but I’m not sure if that specific UEFI boot mode is the cause of grub issues…
I’ll have another crack at the dual system install. and report my results…

So I got through the install process with no errors just like before > removed install media > rebooted… and no grub menu… boots straight into windows 8.1.

Booting off a rEFInd drive shows windows AND Parrot OS available. And booting into Parrot OS actually works…

So… I guess theres something going on that makes the system boot up windows no mater what, unless a boot media like rEFInd gives me more control…

This page has a lot of interesting stuff about ( UEFI + Windows + Linux Co Existence issues ) I’m going to have a look at it.

[Edit] Oh !!! I almost forgot… This laptop will NOT start the text/gui install if in Native UEFI mode. Installation will only start if its in UEFI Hybrid mode. Once install is complete, setting boot mode to either ( UEFI or UEFI hybrid ) does not show the grub boot menu. However… rEFInd usb boot drive will work to load both windows and Parrot OS options in either ( UEFI or UEFI Hybrid )

Got it working.
Just so I’m clear, these steps work on the HP elitebook 9470m with Windows 8.1
Parrot-security-4.7_x64.iso installed

I have the latest BIOS installed from HP’s site.

To get refind boot menu to show up during system start without usb boot media I…
start up parrot os
Install refind deb package
start terminal

cd /boot/efi/EFI
cp -R Boot Boot.bak
cp -R refind/* Boot
cd Boot
mv bootx64.efi bootx64.efi.bak
mv refind_x64.efi bootx64.efi
cd /home

I have another solution.

Access system BIOS and set a prioritized ‘customized boot’ option.

From Bios > Boot Options

Customized Boot is ticked

Under ‘UEFI Boot Order’ I have
USB Hard Drive
Customized Boot
OS Boot Manager
(there are others but those are the top 3…)

My input for Define Customized Boot Option is

This gets grub working ( on HP elitebook 9470m)without the need for refind.

seems to me that another possible solution that bypasses refind would be to make a copy of /boot/efi/EFI/Boot/bootx64.efi and replace it with /boot/efi/EFI/parrot/grubx64.efi

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.