No internet on parrot 4.9 ova

Briefly describe your issue below:
I imported parrot 4.9 ova on virtualbox and when I start it it seems like I cannot have internet access. I can see the ip through ifconfig though. I tried pinging to google.com still no response. Also, I tried opening firefox to browse some page. Still the page keeps loading. Then I installed parrot 4.9 security iso manually on virtualbox and internet works fine on it. I think the issue is with the ova only.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.9 OVA.
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)
No.
List your networking hardware (make, model, firmware version):
Using nat network on virtualbox.
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

I’ve had the same issue in the past but with ubuntu try this.
sudo nano /etc/resolv.conf
add
nameserver 8.8.8.8
then press ctrl s to save and ctrl x to exit.
then reboot

1 Like

Originally by @dmknght

  1. sudo dpkg-reconfigure resolvconf
    alternate sudo resolvconf -u
  2. Dmknght has added a tool called “dns tool” which can fix it easily.
    It can be fixed by running sudo dnstool static opennic or sudo dnstool static 8.8.8.8
3 Likes

Thank you for pointing it out. Not many users really cares about the tools in system that can help them (which was noticed in changelog).
Some more information:

  1. sudo dpkg-reconfigure resolvconf is used for reconfiguration the package. Not recommend
  2. sudo resolvconf -u service resolvconfget the addresses from DHCP server and create a symlink. It may create bug if DHCP server or driver has problem.
  3. The dnstool is a part of AnonSurf which aims fixing DNS issue and add new addresses quickly in a commend. The version 2.12 (4.9 fresh install) is having a bug in dynamic option. It was fixed in newer patch (2.13)
4 Likes

How dependent is the tool on using the google dns configuration?
can it also be ran using cloudflare,or should that be avoided?

yeah it can be run using cloudfare dns as well

1 Like

Just wanted to make sure,thanks for the info…

1 Like