No menu panels on boot up

Hello everyone,

I’m a new Parrot OS user. I installed Parrot Security on my 2017 MacBook Pro w/ Touch Bar. It’s running as a dual-boot OS.

I used the standard installation method to install it on my computer. Everything works fine and I have updated the system to the latest packages. (using a TP-Link TL-WN722N v1.0)
The issue I’m facing is everytime I log-in the menu panels disappear! I have attached a picture to show.

I have tried mate-panel --reset and most commands related to this issue. Nothing seem to be working. I keep re-booting in the hope that it would show but to no avail.

My Mac has a AMD Radeon Pro 560 gpu. Am not sure if it has anything to do with the gpu :open_mouth:

Any help would be appreciated!

1 Like

Hey @s1udge,
The ‘mate-tweak’ did work. I changed from gnome2 to fedora and back. HiDPi doesn’t work as it magnifies the whole screen dis-proportionately! Also, changing the appearance to ‘Regular’ helped! I did change from Auto-Detect -> Regular -> Auto-Detect and on re-booting, the problem came back. Rebooting with the option set to Regular solves it for now…

As requested, this is the log:

-- Logs begin at Tue 2019-02-19 12:19:58 AEDT, end at Tue 2019-02-19 12:25:40 AEDT. --
Feb 19 12:19:58 parrot kernel: Linux version 4.19.0-parrot1-13t-amd64 (team@parrotsec.org) (gcc version 8.2.0 (Debian 8.2.0-13)) #1 SMP Debian 4.19.13-1parro
Feb 19 12:19:58 parrot kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-parrot1-13t-amd64 root=UUID=7945abe6-8ce1-4155-8609-0fa8dd7fa336 ro quiet splash
Feb 19 12:19:58 parrot kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
Feb 19 12:19:58 parrot kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
Feb 19 12:19:58 parrot kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
Feb 19 12:19:58 parrot kernel: x86/fpu: Supporting XSAVE feature 0x008: 'MPX bounds registers'
Feb 19 12:19:58 parrot kernel: x86/fpu: Supporting XSAVE feature 0x010: 'MPX CSR'
Feb 19 12:19:58 parrot kernel: x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
Feb 19 12:19:58 parrot kernel: x86/fpu: xstate_offset[3]:  832, xstate_sizes[3]:   64
Feb 19 12:19:58 parrot kernel: x86/fpu: xstate_offset[4]:  896, xstate_sizes[4]:   64
Feb 19 12:19:58 parrot kernel: x86/fpu: Enabled xstate features 0x1f, context size is 960 bytes, using 'compacted' format.
Feb 19 12:19:58 parrot kernel: BIOS-provided physical RAM map:
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x0000000000000000-0x0000000000057fff] usable
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x0000000000058000-0x0000000000058fff] reserved
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x0000000000059000-0x000000000009dfff] usable
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x000000000009e000-0x00000000000fffff] reserved
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x0000000000100000-0x000000007401afff] usable
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x000000007401b000-0x000000007421cfff] reserved
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x000000007421d000-0x0000000074ca7fff] usable
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x0000000074ca8000-0x0000000074ca8fff] ACPI NVS
Feb 19 12:19:58 parrot kernel: BIOS-e820: [mem 0x0000000074ca9000-0x0000000074ca9fff] reserved

I used ‘journalctl’ to retrieve this, hope it’s the right one!

P.s: Also, regarding uploading pics instead of linking to 3rd party-website, my picture was about 2.1mb and I think the forum allows picture sizes up to 8mb? It didn’t allow me to upload and suggested that I use a file-share website and link it here. Not sure, if the problem is at my end or the servers end, do have a look if you have the access to :slight_smile:

Do, let me know if I can provide more info and I don’t think I have enough financial resources to set ablaze a 3000$ computer haha. Yes, Australia marks up the prices for all imported items unfairly :confused:

1 Like

Hey @s1udge,

I tried copy-pasting the log here but due to the number of characters restrictions, I uploaded the log file. If this is against the rules, do let me know.

As for the OS itself, the menu is working good now. If you find anything interesting in the log file, do let me know :slight_smile:

LOG.log (192.6 KB)

1 Like

Another thing I also realised is that MATE is a demanding de on my mac! The system was getting really hot until I installed ‘macfanctld’ :open_mouth:

Wish Parrot OS Security came as XDE haha

1 Like

Same problem!i have uninstalled that desktop and trying with xcfe.will update