no password box at wifi authentication .

Cant connect to wifi with new wireless device. No space to put password. Cli are not working either
After i change from my wlan 0 which is the broadcom(in the picture) to tp-link device(drivers installed)
The password box dissappear.

What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? Debian Standard

Configured to multiboot with other systems? yes

If there are any error messages or relevant logs, post them below:

What modes do you have your adapters in? How did you set those?

How to check the modes ? Im pretty new in Linux envronment. But im pretty sure it is not in monitor mode.
in ifconfig :
wlan1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 3a:2a:a8:e9:db:7a txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

in iwconfig :
wlan1 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off

The iwconfig command will list the mode here they are both in managed mode you are correct (welcome by the way!) I’m not quite sure why this may be happening but it is most likely just in the gui. If you right click network manager go to add connections and if the wifi network is not already there configure it and include the device you want it to be on and see if that will let you connect. You may also want to enable save the password for all users and check the all users may connect box that are within the new network configuration setup

Tried that still no result… it might be because of the driver. I have install my Tp-link driver

How to make sure the driver that come with it work well ?(I installed the tp link adapter driver from the provided cd ) . I mean how to make sure the driver work well ? I ve test this adapter on windows and the led in the adapter blink while its connecting to my pc… But when using parrot, it didnt blink even after i install the linux driver for the adapter.
The led is in the green thing

Isn’t this the one that only supports injection with version 1?

aaaaaa… what does that mean?

I would follow tp-links installation instructions:

1 Like